app-misc/solaar: bump
authorRobin H. Johnson <robbat2@gentoo.org>
Mon, 18 May 2020 06:15:45 +0000 (23:15 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Mon, 18 May 2020 06:16:42 +0000 (23:16 -0700)
Upstream thinks this might be the final RC before a new
(upstream-stable) release.

Reference: https://github.com/pwr-Solaar/Solaar/issues/673#issuecomment-629839222
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
app-misc/solaar/Manifest
app-misc/solaar/solaar-1.0.2_rc3.ebuild [new file with mode: 0644]

index 571bd048921f42e1a192fc3748a43f29df936ee6..f54ebd2ef116d3c0acf84854010fc6686133f6c6 100644 (file)
@@ -1,3 +1,4 @@
 DIST solaar-1.0.1.tar.gz 1195660 BLAKE2B e6cd89b5735e125dd438255a8961b1d5d38feb515c5097efec0403d99b9db6e29c439c13e279fcffe69cb314bf2650a7a11770830fdf1e971ade27ce8331aed2 SHA512 e0b2bbfd97d9650d94f1a4b47e4e70f09c75f684e7e1d3e67d2cf6dd197109084e941b98333e173fb205d5c9464dd07e17390d9c2d5b46393fee2efdb20429ac
 DIST solaar-1.0.2-rc1.tar.gz 1219777 BLAKE2B aa6780aa4748de97c69c03263e731a47068844e7f4275f87eadd3251e8dcf14b82fdd5ba0eae13492634b7d252340a01b9492cc8948f78fb86c15b4bc4698789 SHA512 1aa5a066c8b735e6525da4da738e9632107867e3d70d67fe7e643debdc9dc7969b033d618ff2c3f538095a9995a7e90d068f9d0f41e858361327c75718dbdb12
 DIST solaar-1.0.2rc2.tar.gz 1212725 BLAKE2B e43dcd013e4251e7450079cafa34e171d10e0144e2b736148a90052e4b2dfed76d6b2c0048a848bb2449febff312d3c058ad03e32f0bdede04cb418adf9d030a SHA512 33a63bc8405a4d48d4dc834d22c0376119a6f611067cd14eaa815503e120a2d877a4f73362aa53bc857aef9626d82413619b1e9a748b9b8bbed0828146c64342
+DIST solaar-1.0.2rc3.tar.gz 1212831 BLAKE2B 5559a0e3a75252914080da7d87739bd8ea867eb09e2a80e31c4057626060c841a60501ac4fcf0f58489e67bed71067c25594ca2250fa961607ba25211350eeab SHA512 fde0533cc5278a831f309e76d449f33b987621d45025879ab1fc9f908073f661e10d6ef030d8455bbc5ca0e82e25f4bb7de1a54327c4b1ecaada08796f46f2e4
diff --git a/app-misc/solaar/solaar-1.0.2_rc3.ebuild b/app-misc/solaar/solaar-1.0.2_rc3.ebuild
new file mode 100644 (file)
index 0000000..5a5a494
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit linux-info udev xdg distutils-r1
+
+DESCRIPTION="A Linux device manager for Logitech's Unifying Receiver peripherals"
+HOMEPAGE="https://pwr-solaar.github.io/Solaar/"
+SRC_URI="https://github.com/pwr-Solaar/Solaar/archive/${PV/_rc/rc}.tar.gz -> ${P/_rc/rc}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc"
+
+RDEPEND="
+       acct-group/plugdev
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+       >=dev-python/pyudev-0.13[${PYTHON_USEDEP}]
+       x11-libs/gtk+:3[introspection]"
+
+S="${WORKDIR}"/Solaar-${PV/_rc/rc}
+
+CONFIG_CHECK="~HID_LOGITECH_DJ ~HIDRAW"
+
+python_prepare_all() {
+       # don't autostart (bug #494608)
+       sed -i \
+               -e '/yield autostart_path/d' \
+               setup.py || die
+
+       sed -i -r \
+               -e '/yield.*udev.*rules.d/{s,/etc,/lib,g}' \
+               setup.py || die
+
+       # grant plugdev group rw access
+       sed -i 's/#MODE=/MODE=/' rules.d/42-logitech-unify-permissions.rules || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       dodoc docs/devices.md
+       if use doc; then
+               dodoc -r docs/*
+       fi
+}