sys-libs/musl-nscd: EAPI=7, resolve prestripped binaries
authorPetr Vaněk <arkamar@atlas.cz>
Mon, 14 Oct 2019 08:10:31 +0000 (10:10 +0200)
committerAnthony G. Basile <blueness@gentoo.org>
Tue, 15 Oct 2019 13:28:34 +0000 (09:28 -0400)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Petr Vaněk <arkamar@atlas.cz>
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
sys-libs/musl-nscd/musl-nscd-9999.ebuild

index cdee80a89452c92528c8bf10068563a6d5a17840..b47444961d2f6b8f01ab367be1484116b670a0ee 100644 (file)
@@ -1,19 +1,32 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit git-r3 systemd
+inherit systemd
 
 DESCRIPTION="musl-nscd is an implementation of the NSCD protocol for the musl libc"
 HOMEPAGE="https://github.com/pikhq/musl-nscd"
-EGIT_REPO_URI="https://github.com/pikhq/musl-nscd"
-EGIT_BRANCH=master
+
+if [[ ${PV} == "9999" ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/pikhq/musl-nscd"
+       EGIT_BRANCH=master
+else
+       SRC_URI="https://github.com/pikhq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
 
 LICENSE="MIT"
 SLOT="0"
 IUSE="minimal"
 
+src_prepare() {
+       eapply_user
+
+       sed -i '/LDFLAGS_AUTO=-s/d' configure || die 'Cannot patch configure file'
+}
+
 src_install() {
        if use minimal; then
                emake DESTDIR="${D}" install-headers