dev-python/ttfquery: version bump with py3 support
authorBen Kohler <bkohler@gentoo.org>
Wed, 1 Jan 2020 17:15:31 +0000 (11:15 -0600)
committerBen Kohler <bkohler@gentoo.org>
Wed, 1 Jan 2020 17:29:28 +0000 (11:29 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
dev-python/ttfquery/Manifest
dev-python/ttfquery/ttfquery-2.0.0_beta1.ebuild [new file with mode: 0644]

index 2ac09d5bd828bdb3556aedd046d1ca9e58558172..16ffe611feae8b96db9d3ce788321dc6d4823f0f 100644 (file)
@@ -1 +1,2 @@
 DIST TTFQuery-1.0.5.tar.gz 17850 BLAKE2B 8545308928c54bf5a0db23878e072c509f64693f8e44888bff5d35fbfc4799c5f8d7094b6fdd2f399c3659dae69415f82186cc36a4ed8058aab1888a8abeef86 SHA512 c5bbdd7cb020dd23f20341d53f400f592654293bd923f64a0d33e269cbd3bc44a97a5cf5bb16485a8978e0d35d729edefbdd6c7d2e51dc65820699bb1df0f60b
+DIST TTFQuery-2.0.0b1.tar.gz 18434 BLAKE2B 27ffe162d2eb1f7642ae54aa74a31ec83161d4c8945162b411cb9bf49dde6f0319b9276ded2abfd92015ee1b7d435dbfcb73c5f882a01fd66dae323814022072 SHA512 883ed4a516ec64e7e5fe13ac0a6e6ba1025e6ea95b293ae092404d0c517aaba8107d63250a458efba01565bb450120073549ea4f45f710873b7f4fe61a80d111
diff --git a/dev-python/ttfquery/ttfquery-2.0.0_beta1.ebuild b/dev-python/ttfquery/ttfquery-2.0.0_beta1.ebuild
new file mode 100644 (file)
index 0000000..6f10397
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+MY_PN="TTFQuery"
+MY_PV="${PV/_beta/b}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Font metadata and glyph outline extraction utility library"
+HOMEPAGE="http://ttfquery.sourceforge.net/ https://pypi.org/project/TTFQuery/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/fonttools[${PYTHON_USEDEP}]
+       dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"