dev-libs/grantlee: remove unused patches
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>
Sat, 3 Sep 2016 15:53:35 +0000 (17:53 +0200)
committerMichael Palimaka <kensington@gentoo.org>
Sun, 4 Sep 2016 18:51:43 +0000 (04:51 +1000)
dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch [deleted file]
dev-libs/grantlee/files/grantlee-slot.patch [deleted file]

diff --git a/dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch b/dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch
deleted file mode 100644 (file)
index 6af42cb..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-From ab40a1ce4bff38fe6c19931bcdb46cdf754e29ed Mon Sep 17 00:00:00 2001
-From: Johannes Huber <johu@gentoo.org>
-Date: Thu, 22 Mar 2012 11:37:57 +0100
-Subject: [PATCH] Search only for qt-test if test build option is enabled.
-
-Build fails on systems were no qt-test is installed and the build option
-for tests is disabled. See downstream bug report
-https://bugs.gentoo.org/show_bug.cgi?id=409131.
----
- templates/CMakeLists.txt    |    6 +++++-
- textdocument/CMakeLists.txt |    6 +++++-
- 2 files changed, 10 insertions(+), 2 deletions(-)
-
-diff --git a/templates/CMakeLists.txt b/templates/CMakeLists.txt
-index 0594cc3..eec0f12 100644
---- a/templates/CMakeLists.txt
-+++ b/templates/CMakeLists.txt
-@@ -1,5 +1,9 @@
--find_package(Qt4 4.5.0 REQUIRED QtCore QtScript QtTest)
-+if (BUILD_TESTS)
-+      find_package(Qt4 4.5.0 REQUIRED QtCore QtScript QtTest)
-+else (BUILD_TESTS)
-+      find_package(Qt4 4.5.0 REQUIRED QtCore QtScript)
-+endif (BUILD_TESTS)
- include(${Grantlee_USE_FILE})
-diff --git a/textdocument/CMakeLists.txt b/textdocument/CMakeLists.txt
-index d456663..8fa2892 100644
---- a/textdocument/CMakeLists.txt
-+++ b/textdocument/CMakeLists.txt
-@@ -1,5 +1,9 @@
--find_package(Qt4 4.5.0 REQUIRED QtCore QtGui QtTest)
-+if (BUILD_TESTS)
-+      find_package(Qt4 4.5.0 REQUIRED QtCore QtScript QtTest)
-+else (BUILD_TESTS)
-+        find_package(Qt4 4.5.0 REQUIRED QtCore QtScript)
-+endif (BUILD_TESTS)
- include(${QT_USE_FILE})
--- 
-1.7.9.4
-
diff --git a/dev-libs/grantlee/files/grantlee-slot.patch b/dev-libs/grantlee/files/grantlee-slot.patch
deleted file mode 100644 (file)
index 814fb9d..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-Install headers to a custom location to permit slotting with Qt4 version.
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 45f8673..7832a3b 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -94,7 +94,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define suffix of library directory name (eg. '6
- set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
- set( PLUGIN_INSTALL_DIR lib${LIB_SUFFIX}/grantlee/${Grantlee_MAJOR_MINOR_VERSION_STRING} )
- set( BIN_INSTALL_DIR bin )
--set( INCLUDE_INSTALL_DIR include )
-+set( INCLUDE_INSTALL_DIR include/grantlee5 )
- set( DATA_INSTALL_DIR share/apps )
- # set up RPATH/install_name_dir
-diff --git a/templates/lib/CMakeLists.txt b/templates/lib/CMakeLists.txt
-index 789205c..7045449 100644
---- a/templates/lib/CMakeLists.txt
-+++ b/templates/lib/CMakeLists.txt
-@@ -79,6 +79,7 @@ add_library(Grantlee5::Templates ALIAS Grantlee_Templates)
- generate_export_header(Grantlee_Templates)
- set_property(TARGET Grantlee_Templates PROPERTY EXPORT_NAME Templates)
- target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
-+target_include_directories(Grantlee_Templates INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>")
- if (BUILD_TESTS)
-   set(GRANTLEE_TESTS_EXPORT "GRANTLEE_TEMPLATES_EXPORT")
-diff --git a/textdocument/lib/CMakeLists.txt b/textdocument/lib/CMakeLists.txt
-index 14163db..7c609f9 100644
---- a/textdocument/lib/CMakeLists.txt
-+++ b/textdocument/lib/CMakeLists.txt
-@@ -24,7 +24,7 @@ add_library(Grantlee_TextDocument SHARED
- generate_export_header(Grantlee_TextDocument)
- add_library(Grantlee::TextDocument ALIAS Grantlee_TextDocument)
- set_property(TARGET Grantlee_TextDocument PROPERTY EXPORT_NAME TextDocument)
--
-+target_include_directories(Grantlee_TextDocument INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>")
- target_link_libraries(Grantlee_TextDocument
-   LINK_PUBLIC Qt5::Gui