x11-misc/xcave: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:07 +0000 (18:40 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:07 +0000 (18:40 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
x11-misc/xcave/xcave-2.4.0.ebuild

index 656794b7c4d58185b658b4df220749b491d22033..3e6245d4498d5d43070e71d8e5aaa7f1bb7a21a9 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 DESCRIPTION="View and manage contents of your wine cellar"
 HOMEPAGE="http://xcave.free.fr/index-en.php"
@@ -10,18 +10,19 @@ SRC_URI="http://${PN}.free.fr/backbone.php?what=download/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
 RESTRICT="test"
 
-RDEPEND=">=x11-libs/gtk+-2.8:2
-       dev-libs/libxml2"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
+RDEPEND="
+       x11-libs/gtk+:2
+       dev-libs/libxml2:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-util/intltool
        sys-devel/gettext
-       dev-util/intltool"
+       virtual/pkgconfig"
 
 src_install() {
        default
-       dodoc ChangeLog TODO
-       rm -rfv "${D}"/usr/doc
+
+       rm -rv "${ED}"/usr/doc || die
 }