dev-python/spyder-notebook: Jupyter notebook integration with Spyder
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Tue, 14 Jan 2020 12:15:16 +0000 (13:15 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 19 Feb 2020 07:02:43 +0000 (09:02 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/spyder-notebook/Manifest [new file with mode: 0644]
dev-python/spyder-notebook/metadata.xml [new file with mode: 0644]
dev-python/spyder-notebook/spyder-notebook-0.2.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
new file mode 100644 (file)
index 0000000..2dc64e8
--- /dev/null
@@ -0,0 +1 @@
+DIST spyder-notebook-0.2.1.tar.gz 3690989 BLAKE2B d03a15d329741f6cc45c91120427f44c08d754f2e472caf0073f44d37874d732ca034ef3a40348d42b75c0862f0a1093ae2fcf7518f4c22032b04672042d3c1d SHA512 7614c62736ecd2894bd18c540057ab6c021991ab48df008b1f189bb93a7b3bc195beb7fcd6895c6fd9069de9ba13cb61fe16702a3a076fd7d9aff1e07afb2025
diff --git a/dev-python/spyder-notebook/metadata.xml b/dev-python/spyder-notebook/metadata.xml
new file mode 100644 (file)
index 0000000..8fc1118
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>andrewammerlaan@riseup.net</email>
+               <name>Andrew Ammerlaan</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.2.1.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.2.1.ebuild
new file mode 100644 (file)
index 0000000..2b00297
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Jupyter notebook integration with Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/nbformat[${PYTHON_USEDEP}]
+       dev-python/notebook[${PYTHON_USEDEP}]
+       dev-python/psutil[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       >=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+       dev-python/flaky[${PYTHON_USEDEP}]
+       dev-python/pytest-mock[${PYTHON_USEDEP}]
+       dev-python/pytest-qt[${PYTHON_USEDEP}] )"
+
+DOCS=( "README.md" "RELEASE.md" "CHANGELOG.md" "doc/example.gif" )
+
+# Tests do not work inside virtx/emerge for some reason, core dumped
+RESTRICT="test"
+distutils_enable_tests pytest
+
+pytthon_test() {
+       virtx pytest -vv
+}