dev-libs/libgit2: Bump to 0.28.3
authorMichał Górny <mgorny@gentoo.org>
Wed, 14 Aug 2019 20:58:14 +0000 (22:58 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 14 Aug 2019 20:58:41 +0000 (22:58 +0200)
Bug: https://bugs.gentoo.org/692166
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/libgit2/Manifest
dev-libs/libgit2/libgit2-0.28.3.ebuild [new file with mode: 0644]

index 0ab25487acaee79561914df36d1c9ff9c01eecd0..9bc877f45ed186889c63086d9aa58ad50fdd32a0 100644 (file)
@@ -1,2 +1,3 @@
 DIST libgit2-0.26.8.tar.gz 4742478 BLAKE2B 31326987961ed42740f6c0ddce6a80c278175899a62cabd65ce9eef60854553e6a91fd9947ca23945104d4e1b46f9ab0bb1a1a793d8dd87bed792528e5c32839 SHA512 efb9229b2882ac36910d75778d7431bec40f3529f2ad2dd6a950d5580ceb0d4dd798242a422ea6cbb880f515df4dfbb7055a65dd5a8106696d3d458851fca56e
 DIST libgit2-0.28.2.tar.gz 4987586 BLAKE2B cf791adb173050b4b153062ff5fdc923289462677ce34af1077d228a95c4d9d7e9b836aee44dc79f079f42c910c4b4548241ec7ff16665ce49e319ccd38d4c7a SHA512 0879c162e2e1dc00eadfbda22cd1f9d3a95b4ec2b653c108983f37c2f695140882de4d50d7cbc04ced247125a4e9fe6df16130e1267891aecdb2411d920db5c6
+DIST libgit2-0.28.3.tar.gz 4988580 BLAKE2B 93d87792b0aef6383845230880d749fa77f28ac8ece4564abf041ccbb672d17e6efb1ef9503879d45cf5f78b6f1e54dd2b2ab9eac0fb09ddb445310484bbd7fc SHA512 15444823b7d4885f7b8c3982f8905efc4a75913de016a9b2e0a24d5ce9746e6a549dffd5469036529557feff2ce7ece9328266eb312c80b96091ce0f65ee97ee
diff --git a/dev-libs/libgit2/libgit2-0.28.3.ebuild b/dev-libs/libgit2/libgit2-0.28.3.ebuild
new file mode 100644 (file)
index 0000000..89a49f8
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit cmake-utils python-any-r1
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~ppc-macos"
+fi
+
+DESCRIPTION="A linkable library for Git"
+HOMEPAGE="https://libgit2.github.com/"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0/28"
+IUSE="examples gssapi libressl +ssh test +threads trace"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       sys-libs/zlib
+       net-libs/http-parser:=
+       gssapi? ( virtual/krb5 )
+       ssh? ( net-libs/libssh2 )
+"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       virtual/pkgconfig
+"
+
+S=${WORKDIR}/${P/_/-}
+
+src_configure() {
+       local mycmakeargs=(
+               -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
+               -DBUILD_CLAR=$(usex test)
+               -DENABLE_TRACE=$(usex trace)
+               -DUSE_GSSAPI=$(usex gssapi)
+               -DUSE_SSH=$(usex ssh)
+               -DTHREADSAFE=$(usex threads)
+       )
+       cmake-utils_src_configure
+}
+
+src_test() {
+       if [[ ${EUID} -eq 0 ]] ; then
+               # repo::iterator::fs_preserves_error fails if run as root
+               # since root can still access dirs with 0000 perms
+               ewarn "Skipping tests: non-root privileges are required for all tests to pass"
+       else
+               local TEST_VERBOSE=1
+               cmake-utils_src_test -R offline
+       fi
+}
+
+src_install() {
+       cmake-utils_src_install
+       dodoc docs/*.{md,txt}
+
+       if use examples ; then
+               find examples -name '.gitignore' -delete || die
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+}