app-admin/puppet-agent: bup for release
authorMatthew Thode <mthode@mthode.org>
Tue, 15 Sep 2015 18:31:51 +0000 (13:31 -0500)
committerMatthew Thode <mthode@mthode.org>
Tue, 15 Sep 2015 18:31:51 +0000 (13:31 -0500)
Package-Manager: portage-2.2.20.1

app-admin/puppet-agent/Manifest
app-admin/puppet-agent/puppet-agent-1.2.4.ebuild [new file with mode: 0644]

index 81fb2e1cba27d09d855340e6521df59b3c37f922..429ae4dd2e2a3f71a0635ce092ce0188f3acd116 100644 (file)
@@ -1,2 +1,4 @@
 DIST puppet-agent_1.2.2-1wheezy_amd64.deb 14860604 SHA256 5910ff850e8814092b50dc70a68d8c5497d5fe3d960bfef9cd13f8dc689dc665 SHA512 ad11b0ba820186f4b315ac156e8bf78348acd69d11e4c03cb12314fc73e4e3fbfef0814664e7fd04f692e8db42f9e137194e267354b2fc4ec8dda424af9f5d98 WHIRLPOOL 25c42e9f7871ccf61eb55b83327813e6090ee359c42e1e473ef09155db69adebfe412fd61a5752b4b634e5ad8aa7bd45d4a86f7e5ba29c1bdb74033b91f45c3f
 DIST puppet-agent_1.2.2-1wheezy_i386.deb 14816930 SHA256 092b8bfe1e1156322d0ab68d411487c80146bd778916409b1c907791f41a49c8 SHA512 50879ce4eebcd451dafb33cb7a12c36ee9bcaedfc29ffa0d60552efa5aa4cd66d0007061d28a80d31615c67442f8526863185e6753418772d8275e58454d6886 WHIRLPOOL 7abb0b6f52f5dd07a5ccb56b1c795c05f8c4efd18665d2ca209400e51419e4ae335e630a845c031a47df09d96ce20fbc92d7cafa082deb3872306daf74838612
+DIST puppet-agent_1.2.4-1wheezy_amd64.deb 15187770 SHA256 a711255c7b5aab5f1a653fcbe461db0934645b1da876f24595d531c7ad8c81d4 SHA512 dc7656a7f79f1f2e5144bf625b87548ed1b78290ae03c969abb850f0b1c346536c37c2b204ac0e6add830c1fd692ca4f946ea01bba50bb9794c094069f237d73 WHIRLPOOL 3809a0f9c5db1c73c6edcc344e6fdc7fb5acf340e36225611c72088175fe64ea26c3770ba126a61ed91fa275cf898828d9d192872a216a52b8345f25de1df7e6
+DIST puppet-agent_1.2.4-1wheezy_i386.deb 15122670 SHA256 33e9b16ea215089e7a89288faebd4767163e05d7c4a9d5c51ca71b041496c204 SHA512 944f6388d317fab9a2714a6cdc57e713a973d3c1df259b3358be3a0d737878df9f1d66186af8aea0cc768e55650f1dd1d3ef8682b942728fba45e7c0bca20867 WHIRLPOOL bd5710845a9c8f27fb566ead63e45649fb3854200df0259c76b9478d93792b453a9d5cf4fdc20112991d4d091c82143b7504b51be65815b2dcb67796f275303d
diff --git a/app-admin/puppet-agent/puppet-agent-1.2.4.ebuild b/app-admin/puppet-agent/puppet-agent-1.2.4.ebuild
new file mode 100644 (file)
index 0000000..2af998e
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+       amd64? ( ${SRC_BASE}_amd64.deb )
+       x86?   ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+       !app-admin/mcollective
+       !app-admin/puppet
+       !dev-ruby/hiera
+       !dev-ruby/facter
+       !app-emulation/virt-what"
+
+DEPEND="
+       ${CDEPEND}"
+RDEPEND="${CDEPEND}
+       sys-apps/dmidecode
+       selinux? (
+               sys-libs/libselinux[ruby]
+               sec-policy/selinux-puppet
+       )
+       puppetdb? ( >=dev-ruby/puppetdb-termini-3.0.1-r2 )"
+
+S=${WORKDIR}
+
+src_install() {
+       # conf.d
+       doconfd etc/default/puppet
+       doconfd etc/default/mcollective
+       # logrotate.d
+       insinto /etc/logrotate.d
+       doins etc/logrotate.d/mcollective
+       # puppet itself
+       insinto /etc/puppetlabs
+       doins -r etc/puppetlabs/*
+       # logdir for systemd
+       dodir var/log/puppetlabs/puppet/
+       fperms 0750 var/log/puppetlabs/puppet/
+       # the rest
+       insinto /opt
+       doins -r opt/*
+       fperms 0750 /opt/puppetlabs/puppet/cache
+       # init
+       newinitd "${FILESDIR}/puppet.initd" puppet
+       newinitd "${FILESDIR}/mcollective.initd" mcollective
+       systemd_dounit "${FILESDIR}/puppet.service"
+       systemd_dounit "${FILESDIR}/mcollective.service"
+       systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+       # symlinks
+       chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+       chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+       dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+       dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+       dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+       dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+       dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+       dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+       dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+       dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+       dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}