net-nds/rpcbind: Bump to version 1.2.5
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 26 Aug 2018 18:05:44 +0000 (20:05 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sun, 26 Aug 2018 18:05:44 +0000 (20:05 +0200)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

net-nds/rpcbind/Manifest
net-nds/rpcbind/metadata.xml
net-nds/rpcbind/rpcbind-1.2.5.ebuild [new file with mode: 0644]

index aa93e472e8cde029fafb56debc2ecd35a83ebc0c..f3285ad88147128e44525321e0a39e1d6be27c22 100644 (file)
@@ -1 +1,2 @@
 DIST rpcbind-0.2.4.tar.bz2 122781 BLAKE2B ac1c374a1081559bf09bc209256daa1bb530d71f0c7fe45cec4c9b87cf110c15251a05dce2cf2b78ffa4d902f817efed30350ad08a23e12a7f219f10fe626aa8 SHA512 f3966a7284e94bdf120a9b3f0dd66efa1fe8761df2313545a031f77b7c06e27d7955d2780469943deb537d34f95c4cf3f30de523ec9fab9f571322d7224b210c
+DIST rpcbind-1.2.5.tar.bz2 123502 BLAKE2B de0d10406aeffd75195c1fa1d0179b2c7c0ba54c3f3ac58ce9d7e9448d1dbe91a296ad69c45dee115e0a739aa9cfec53b750d3a5ca405e16605a92bbb2006859 SHA512 e884c4757950ccead0f9a07f50625a63e6f18f9bfae9fcfffa3e5fa4b7a66c3a99d9fa303061848fe8211509d5456f24ff26e4579af6e161a35522268f3ef3e4
index 664c6a547a0134938b31f61b97985ea0b1219ff9..8b85a22052b29ba3a98bd1e6e3bf6a058c04e0e3 100644 (file)
@@ -5,6 +5,7 @@
                <email>base-system@gentoo.org</email>
        </maintainer>
        <use>
+               <flag name="remotecalls">Enable remote calls</flag>
                <flag name="warmstarts">Enables rpcbind to cache configuration for warm restarts</flag>
        </use>
        <upstream>
diff --git a/net-nds/rpcbind/rpcbind-1.2.5.ebuild b/net-nds/rpcbind/rpcbind-1.2.5.ebuild
new file mode 100644 (file)
index 0000000..7e3bbea
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
+       inherit autotools git-r3
+else
+       SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="portmap replacement which supports RPC over various protocols"
+HOMEPAGE="https://sourceforge.net/projects/rpcbind/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="debug remotecalls selinux systemd tcpd warmstarts"
+REQUIRED_USE="systemd? ( warmstarts )"
+
+CDEPEND=">=net-libs/libtirpc-0.2.3:=
+       systemd? ( sys-apps/systemd:= )
+       tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${CDEPEND}
+       virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+       selinux? ( sec-policy/selinux-rpcbind )"
+
+src_prepare() {
+       default
+       [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --bindir="${EPREFIX}"/sbin
+               --sbindir="${EPREFIX}"/sbin
+               --with-statedir="${EPREFIX}"/run/${PN}
+               --with-systemdsystemunitdir=$(usex systemd "$(systemd_get_systemunitdir)" "no")
+               $(use_enable debug)
+               $(use_enable remotecalls rmtcalls)
+               $(use_enable warmstarts)
+               $(use_enable tcpd libwrap)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
+       newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}