media-fonts/oxygen-fonts: Switch to cmake-utils, kde.org, xdg-utils
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 11 Nov 2019 23:50:31 +0000 (00:50 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 12 Nov 2019 01:10:00 +0000 (02:10 +0100)
This goes half way back to -r0 which already called the cmake-utils
phase functions instead of kde5 ones. Keep minimum versions set by
kde5.eclass at commit time.

Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-fonts/oxygen-fonts/oxygen-fonts-5.4.3-r1.ebuild

index 4e9dd767cbfd5cf3d1f7205a1cd0a9ec7a30a395..4e52cb0823ec8e0c726548facfcb886f46d6e0a4 100644 (file)
@@ -3,21 +3,20 @@
 
 EAPI=7
 
-KDE_AUTODEPS="false"
-KDE_DEBUG="false"
-inherit kde5 font
+inherit cmake-utils font kde.org xdg-utils
 
 DESCRIPTION="Desktop/GUI font family for integrated use with the KDE Plasma desktop"
 HOMEPAGE="https://cgit.kde.org/oxygen-fonts.git"
 SRC_URI="mirror://kde/unstable/plasma/$(ver_cut 1-3)/${P}.tar.xz"
 
 LICENSE="OFL-1.1"
+SLOT="5"
 KEYWORDS="amd64 ~arm x86"
 IUSE=""
 
 BDEPEND="
-       $(add_frameworks_dep extra-cmake-modules)
-       $(add_qt_dep qtcore)
+       >=kde-frameworks/extra-cmake-modules-5.60.0:5
+       >=dev-qt/qtcore-5.12.3:5
        media-gfx/fontforge
 "
 
@@ -26,13 +25,15 @@ DOCS=( README.md )
 PATCHES=( "${FILESDIR}/${P}-fix-d-and-t-accents.patch" )
 
 src_configure() {
+       xdg_environment_reset
+
        local mycmakeargs=(
                -DOXYGEN_FONT_INSTALL_DIR="${FONTDIR}"
        )
-       kde5_src_configure
+       cmake-utils_src_configure
 }
 
 src_install() {
-       kde5_src_install
+       cmake-utils_src_install
        font_src_install
 }