dev-qt/qt-creator: add plugins/fix build for 9999
authorJimi Huotari <chiitoo@gentoo.org>
Wed, 25 Sep 2019 12:23:30 +0000 (15:23 +0300)
committerDavide Pesavento <pesa@gentoo.org>
Sat, 26 Oct 2019 19:28:34 +0000 (21:28 +0200)
New plugins Boot2Qt [1] and Chrome Trace Format Visualizer [2].

1. https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=5942b824
2. https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=7fec4182

Reported-by: Manuel Nickschas <sputnick@quassel-irc.org>
Closes: https://github.com/gentoo/gentoo/pull/13036
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Signed-off-by: Davide Pesavento <pesa@gentoo.org>
dev-qt/qt-creator/metadata.xml
dev-qt/qt-creator/qt-creator-9999.ebuild

index 75d3a6852989e848abfa7655e27ccb56777d40ec..457cf40adb4a3f27c4326c2dc22eaeb39245055d 100644 (file)
                <flag name="baremetal">Build plugin for bare metal devices</flag>
                <flag name="bazaar">Add support for <pkg>dev-vcs/bzr</pkg> version control system</flag>
                <flag name="beautifier">Build the beautifier plugin (supports astyle, clang-format, and uncrustify)</flag>
+               <flag name="boot2qt">Build plugin for Boot2Qt devices</flag>
                <flag name="clang">Build clang-based plugins (code model, formatting, refactoring, static analysis)</flag>
                <flag name="clearcase">Add support for IBM ClearCase version control system (requires manual installation of ClearCase client)</flag>
                <flag name="cmake">Enable cmake project manager plugin</flag>
                <flag name="cppcheck">Enable integration with <pkg>dev-util/cppcheck</pkg></flag>
+               <flag name="ctfvisualizer">Build the Chrome Trace Format Visualizer plugin</flag>
                <flag name="designer">Enable designer for QtWidgets-based UIs</flag>
                <flag name="glsl">Enable GLSL source code editor</flag>
                <flag name="help">Build the help plugin</flag>
index 87ff878b2085d591657d3fa8bac8b720add400ec..6d0e795605f6a60794a5a780ccefe75e9a09a238 100644 (file)
@@ -25,14 +25,15 @@ fi
 
 # TODO: unbundle sqlite and KSyntaxHighlighting
 
-QTC_PLUGINS=(android +autotest baremetal bazaar beautifier
+QTC_PLUGINS=(android +autotest baremetal bazaar beautifier boot2qt
        '+clang:clangcodemodel|clangformat|clangpchmanager|clangrefactoring|clangtools' clearcase
-       cmake:cmakeprojectmanager cppcheck cvs +designer git glsl:glsleditor +help ios lsp:languageclient
-       mercurial modeling:modeleditor nim perforce perfprofiler python:pythoneditor qbs:qbsprojectmanager
-       +qmldesigner qmlprofiler qnx remotelinux scxml:scxmleditor serialterminal silversearcher subversion
-       valgrind winrt)
+       cmake:cmakeprojectmanager cppcheck ctfvisualizer cvs +designer git glsl:glsleditor +help ios
+       lsp:languageclient mercurial modeling:modeleditor nim perforce perfprofiler python:pythoneditor
+       qbs:qbsprojectmanager +qmldesigner qmlprofiler qnx remotelinux scxml:scxmleditor serialterminal
+       silversearcher subversion valgrind winrt)
 IUSE="doc systemd test +webengine ${QTC_PLUGINS[@]%:*}"
 REQUIRED_USE="
+       boot2qt? ( remotelinux )
        clang? ( test? ( qbs ) )
        qnx? ( remotelinux )
 "
@@ -128,7 +129,7 @@ src_prepare() {
        fi
        if ! use perfprofiler; then
                rm -rf src/tools/perfparser || die
-               if ! use qmlprofiler; then
+               if ! use ctfvisualizer && ! use qmlprofiler; then
                        sed -i -e '/tracing/d' src/libs/libs.pro tests/auto/auto.pro || die
                fi
        fi