app-portage/eix: Version bump (v0.33.11)
authorMikle Kolyada <zlogene@gentoo.org>
Mon, 30 Mar 2020 08:00:33 +0000 (11:00 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Mon, 30 Mar 2020 08:00:33 +0000 (11:00 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-portage/eix/Manifest
app-portage/eix/eix-0.33.11.ebuild [new file with mode: 0644]

index b6b5891bbfb20bcd61a9d5869c130c0608e7af86..03b7b0eb348ebd3bbc7198a288baa544166a8b71 100644 (file)
@@ -1 +1,2 @@
+DIST eix-0.33.11.tar.xz 623256 BLAKE2B 756feed85cb4f40ef9228a03d2a8b8470eb6017b00d93b364d67e3d11ecaacce2bb9c6afed388d9f70dfcb7a0b9ece13ca6ee523f5839b7d9bf80cf3b2721524 SHA512 2829d1482abfe479ae71e8b00da07abe74ba3090ba2a3f9d9a93437cb2d4d64213968bcd6c082a6703ec1d9c36dfcfaa0850172f3ffd4d256f553b98eeaf29e6
 DIST eix-0.33.9.tar.xz 627944 BLAKE2B cb4add12301a4f08b6ca052df92be34c8a448b386aa700e8ac7e1fbe8563cd76047994007ac94d8989747d843f70a5e1731b401510f58badd9811b30c2ce3be8 SHA512 7539a91d5b5343532ceab1f4aeb82a95413c39b1a57b9e7922032acc937cc8b839494fc40f3510218349561c6d50e89e1861d2fce5e60eabed2465316b28a756
diff --git a/app-portage/eix/eix-0.33.11.ebuild b/app-portage/eix/eix-0.33.11.ebuild
new file mode 100644 (file)
index 0000000..1f78164
--- /dev/null
@@ -0,0 +1,107 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 flag-o-matic tmpfiles
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc nls sqlite"
+
+BOTHDEPEND="nls? ( virtual/libintl )
+       sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+       >=app-shells/push-2.0-r1
+       >=app-shells/quoter-3.0_p2-r1"
+DEPEND="${BOTHDEPEND}
+       app-arch/xz-utils
+       nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+       # remove stale cache file to prevent collisions
+       local old_cache=${EROOT}/var/cache/${PN}
+       if [[ -f ${old_cache} ]]; then
+               rm "${old_cache}" || die
+       fi
+}
+
+src_prepare() {
+       default
+       sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+
+       sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
+               -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
+               -i src/eix-functions.sh.in || die
+       sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
+               -i src/Makefile.am || die
+       eautoreconf
+}
+
+src_configure() {
+       local myconf=(
+               $(use_enable debug paranoic-asserts)
+               $(use_enable nls)
+               $(use_with doc extra-doc)
+               $(use_with sqlite)
+
+               # default configuration
+               $(use_with prefix always-accept-keywords)
+               --with-dep-default
+               --with-required-use-default
+
+               # paths
+               --with-portage-rootpath="${ROOTPATH}"
+               --with-eprefix-default="${EPREFIX}"
+
+               # build a single executable with symlinks
+               --disable-separate-binaries
+               --disable-separate-tools
+
+               # used purely to control/disrespect *FLAGS
+               --disable-debugging
+               --disable-new_dialect
+               --disable-optimization
+               --disable-strong-optimization
+               --disable-security
+               --disable-nopie-security
+               --disable-strong-security
+       )
+
+       # https://github.com/vaeth/eix/issues/35
+       append-cxxflags -std=c++14
+
+       # work around https://github.com/vaeth/eix/issues/64, bug#687988
+       local -x mv_fCXXFLAGS_cache='-mindirect-branch=thunk'
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+       dobashcomp bash/eix
+       dotmpfiles tmpfiles.d/eix.conf
+
+       rm -r "${ED}"/usr/bin/eix-functions.sh || die
+
+}
+
+pkg_postinst() {
+               tmpfiles_process eix.conf
+
+       local obs=${EROOT}/var/cache/eix.previous
+       if [[ -f ${obs} ]]; then
+               ewarn "Found obsolete ${obs}, please remove it"
+       fi
+}
+
+pkg_postrm() {
+       if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+               rm -rf "${EROOT}/var/cache/${PN}" || die
+       fi
+}