dev-python/pyicu: bump to 2.4.3
authorMarek Szuba <marecki@gentoo.org>
Tue, 21 Apr 2020 23:10:19 +0000 (00:10 +0100)
committerMarek Szuba <marecki@gentoo.org>
Tue, 21 Apr 2020 23:21:57 +0000 (00:21 +0100)
Nb. tested on pypy3 too and it does NOT work, there are test failures.

Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-python/pyicu/Manifest
dev-python/pyicu/pyicu-2.4.3.ebuild [new file with mode: 0644]

index 40ab56c8000fdf348ef95d23e97b31f16acec233..29a8a6a4addb3e14981d137f80bca9a366a52f18 100644 (file)
@@ -1 +1,2 @@
 DIST PyICU-2.4.2.tar.gz 219356 BLAKE2B dc6ad1e8944e43560314e9dbfcd37e58b52b50874656f7ca66497a317b03bb9bf988515417660be87bb2e73e0484e5870cd3db2c5eab47fda1223e7514935fb0 SHA512 3cd1f632c2551dce3d721c54190a19c2a46e2554ef54915c9e07b133fa4a499b1a8c49f406abe9777721903799eb23a2d55d3b1aadd758870f8bd591f143a05b
+DIST PyICU-2.4.3.tar.gz 219819 BLAKE2B 5e4b9ecab9e726aa05ae4a30d3b277dec3a94a2e0393a7cd9a9f247c73f02051649f03079b3b5f6d5a1745f00d2dc367066de8e93cafe3291cce7aa09884d7af SHA512 77b81b0e9a17972696967ebc0421d05c1119a43c7e853f8d939390dddefa4a2a35dd316e08c10c10a283472bb64738016e47c5f45c7c6191d9dba296057740a0
diff --git a/dev-python/pyicu/pyicu-2.4.3.ebuild b/dev-python/pyicu/pyicu-2.4.3.ebuild
new file mode 100644 (file)
index 0000000..0d484ef
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="PyICU"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="https://github.com/ovalhub/pyicu"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+       dev-libs/icu:="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest