dev-python/PySensors-0.0.4: version bump for Python 3 support
authorFabian Groffen <grobian@gentoo.org>
Sat, 7 Dec 2019 08:20:32 +0000 (09:20 +0100)
committerFabian Groffen <grobian@gentoo.org>
Sat, 7 Dec 2019 08:20:32 +0000 (09:20 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
dev-python/PySensors/Manifest
dev-python/PySensors/PySensors-0.0.4.ebuild [new file with mode: 0644]

index a351f0ae7389f8296a82ed77b9842131ed2b9485..0f98bbc13f4a4061550ba72a6397d4b70097d652 100644 (file)
@@ -1 +1,2 @@
 DIST PySensors-0.0.3.tar.gz 5109 BLAKE2B 8d537c121540c8e28d0f8cfc45152abea0e312c48a460e877935c7d8639710c8046a96f598c724082870ad7c0d528621bce85d8616485336c2b4f8ac2ebe7579 SHA512 b9ae61ee9049e1edd3fdee7b122c0f9aa19677aee401c910fcaec5a6bc95a0628d6b7eb2b59f1d14196bee22395819f4980d328d60dd69b0a413f7d08041f159
+DIST PySensors-0.0.4.tar.gz 10599 BLAKE2B be3a3692a846e5339758eff4f4396dd15bf96b3d20bc40df45436ce58381ac87503bca190fa215121506ecf9ce5175b254d93142ee881c4d5b8ef8e045854659 SHA512 8e6b2beee9bf282f073618c0b45e53330ce82c9fc9c6565a3c6b5f812231421c8c6e15ccc4fc92cda67ed08df5c482577d4a34720c920dbba7604f2b7c3ba21c
diff --git a/dev-python/PySensors/PySensors-0.0.4.ebuild b/dev-python/PySensors/PySensors-0.0.4.ebuild
new file mode 100644 (file)
index 0000000..4b2716c
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 python3_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to libsensors (via ctypes)"
+HOMEPAGE="https://pypi.org/project/PySensors/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=sys-apps/lm-sensors-3"