net-misc/rclone-1.50.0 version bump
authorAlexander Kurakin <kuraga333@mail.ru>
Tue, 29 Oct 2019 15:59:25 +0000 (18:59 +0300)
committerJason Zaman <perfinion@gentoo.org>
Fri, 24 Jan 2020 19:49:11 +0000 (03:49 +0800)
Signed-off-by: Alexander Kurakin <kuraga333@mail.ru>
Closes: https://bugs.gentoo.org/698854
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
net-misc/rclone/Manifest
net-misc/rclone/rclone-1.50.0.ebuild [new file with mode: 0644]
net-misc/rclone/rclone-9999.ebuild

index c1c2696e274909045fa06aee1d747573b5523994..c25d0f3fb744531cbad485ae1743bad192f550b8 100644 (file)
@@ -1,3 +1,4 @@
 DIST rclone-1.45.tar.gz 16494131 BLAKE2B 17ca4182af4efe23a367fc38226dc7fe146da55fea47a5f76773f1dcc3d3b629cca7964ffe41aa1e4dbd2fe36bd80545f336d2823a25ebb6b3effc768d4b46d2 SHA512 348dbd6a069f736219b7f925b6aa5234a4d70724ee5bfdb56067241063be36c44a091a37acb3285627803fa013329a6ef804aab4c0070ddaf322c5324b9e2a5a
 DIST rclone-1.47.0.tar.gz 17282254 BLAKE2B 57c4f3576427778db0fdc523d8b95b33db5cebfb0081d927abc8925eeaf90c0d2079f1d9572e81faac41e98cfee3028f39c9aed89e6db17188efb3541e3daa6a SHA512 90e68021f589bfad95989b45d91c47da63066e9bc60040052e866d1c7e420bc2784335cc5dbab0e4372c4f8686acb0a65853877c41081c8406eddada42550125
 DIST rclone-1.49.1.tar.gz 18196519 BLAKE2B 22a2f5984f65a64972c40fa845f0b4e5a8d52840ee9dc35463605e3eea399ab01a3b36f1f25a07d5c583829684863b8cbeaf82282e9b59ca994a8fa1d9558ebf SHA512 05b864932fdec7d1bc7185a4e2d33b7bd06b840399f100b1f58806e2ab6f752e4b7cb0f2691cfa92785f45b2f587aebaf7c9e5ab256c2d9b63c262d90ea1e3ac
+DIST rclone-1.50.0.tar.gz 18566931 BLAKE2B cfaf983ae972606b8ccc56ba505aec65bd7e6427f0b16f7e6187b079116b47eb3d297a99b505782c2bb5b64a5c8bf4e5b7beaee9dad5718ec952033ceca0945c SHA512 df805dc711ecf60b869ec957d224676643bcb6eac756470d2194338b9cc34e2a657d286d4a4308c743847fc11aa821b106888eb6ab9f04677bc70747c73fc5c1
diff --git a/net-misc/rclone/rclone-1.50.0.ebuild b/net-misc/rclone/rclone-1.50.0.ebuild
new file mode 100644 (file)
index 0000000..8bec0f1
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-build bash-completion-r1
+EGO_PN="github.com/rclone/${PN}"
+
+if [[ ${PV} == *9999* ]]; then
+       inherit golang-vcs
+else
+       KEYWORDS="~amd64 ~arm ~x86"
+       EGIT_COMMIT="v${PV}"
+       SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+       dobin ${PN}
+       doman src/${EGO_PN}/${PN}.1
+       dodoc src/${EGO_PN}/README.md
+
+       ./rclone genautocomplete bash ${PN}.bash || die
+       newbashcomp ${PN}.bash ${PN}
+
+       ./rclone genautocomplete zsh ${PN}.zsh || die
+       insinto /usr/share/zsh/site-functions
+       newins ${PN}.zsh _${PN}
+}
index 8c2e65193573ccd61d43208f7c31d03c66e328e9..8bec0f181760eea10866901d538dfa0386c3ea5c 100644 (file)
@@ -1,7 +1,8 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
+
 inherit golang-build bash-completion-r1
 EGO_PN="github.com/rclone/${PN}"