dev-python/pycollada: bump to 0.7.1
authorBernd Waibel <waebbl@gmail.com>
Fri, 17 Apr 2020 13:36:31 +0000 (15:36 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 21 Apr 2020 08:16:09 +0000 (11:16 +0300)
Closes: https://bugs.gentoo.org/717566
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Bernd Waibel <waebbl@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/pycollada/Manifest
dev-python/pycollada/metadata.xml
dev-python/pycollada/pycollada-0.7.1.ebuild [new file with mode: 0644]

index 1b273279a3ad51e0ea0f9ccdad9e2e3eeb545a19..47d5abe8cb17b43b51ef3c7af57a38e16d57dc33 100644 (file)
@@ -1 +1,2 @@
 DIST pycollada-0.6.tar.gz 3109963 BLAKE2B 92e9b3a28c959700fad4f4af1c6375f47b1a3cabb4ff3b8eec47a5625bd680d7088b7c9677e0d395f3be296d555996e5e5819f11ab82a0fa37b0c6fbec33795f SHA512 043eaafbd97a588897870e89202e281777094e4bf63ea56a979b6f7aef7ad549fc2b71f3b575c0b9c413bc10756ba36e02cc7cbd497a6cbaa51f06e99b34f0cd
+DIST pycollada-0.7.1.tar.gz 3526373 BLAKE2B 9adcbff206bc856fce1eef1784734c5604800cff350d32a83d53a4eaf965673adac797f510662dffc70fcfd76a7102fdb9321ead89d765954ffccc9338df446a SHA512 ac4d88b2398bf0364beaaf3e2e468be9131dc0f8088bfce8be18d9eb5a7c093db84a364931884fa7c493dfae81036ec63bc7c689ebf49e961eefc0c4853a0131
index 04ffb3bbb4c8b10ef253461888ba45f90077d138..e0cc39c32687db0941e17268843c19412733dcdb 100644 (file)
@@ -10,8 +10,9 @@
        <name>Proxy Maintainers</name>
 </maintainer>
 <longdescription>
-A python COLLADA library, which can be used to create, edit and load
-COLLADA documents.
+A python module for creating, editing and loading COLLADA, which is a
+COLLAborative Design Activity for establishing an interchange file format
+for interactive 3D applications.
 </longdescription>
 <upstream>
        <remote-id type="github">pycollada/pycollada</remote-id>
diff --git a/dev-python/pycollada/pycollada-0.7.1.ebuild b/dev-python/pycollada/pycollada-0.7.1.ebuild
new file mode 100644 (file)
index 0000000..9e07aa9
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing COLLADA documents"
+HOMEPAGE="https://pycollada.readthedocs.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+       dev-python/lxml[${PYTHON_USEDEP}]
+       dev-python/numpy[${PYTHON_USEDEP}]
+       >=dev-python/python-dateutil-2.2[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.md COPYING README.markdown )
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+python_install_all() {
+       if use examples ; then
+               insinto /usr/share/${P}/
+               doins -r examples
+       fi
+
+       distutils-r1_python_install_all
+}
+
+python_install() {
+       distutils-r1_python_install
+
+       # ensure data files for tests are getting installed too
+       python_moduleinto collada/tests/
+       python_domodule collada/tests/data
+}