Revert "media-libs/giflib: security cleanup (bug #711272)"
authorThomas Deutschmann <whissi@gentoo.org>
Wed, 25 Mar 2020 21:29:04 +0000 (22:29 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 25 Mar 2020 21:30:10 +0000 (22:30 +0100)
This reverts commit d5eac496a50b7aeb6e2d156658348ac8cfb505bf.

Bug: https://bugs.gentoo.org/711272
Bug: https://bugs.gentoo.org/711908
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
media-libs/giflib/Manifest
media-libs/giflib/giflib-5.1.4.ebuild [new file with mode: 0644]

index 9f17d63b72cfcf876475792325074bf61bc169ff..a6794c6fbe7bd155e2fea444ceccd15320a92b6f 100644 (file)
@@ -1 +1,2 @@
+DIST giflib-5.1.4.tar.bz2 639703 BLAKE2B 5176fbd94c37a86a7f7a3964b6b5f2637d76ba5d40e594a0db52a3a09e22b915a0388fc9bd2f1446dcf66b3b9c0d76741583e4d5d3f7362fa3997e8b26503fc4 SHA512 32b5e342056c210e6478e9cb3b6ceec9594dcfaf34feea1eb4dad633a081ed4465bceee578c19165907cb47cb83912ac359ceea666a8e07dbbb5420f9928f96d
 DIST giflib-5.2.1.tar.gz 444187 BLAKE2B 8c1e105bbb65dc7ab103976caed70834356440f381ec5118311882fb1c558bb65f6c1081e5767f9835087860de44df5dfcd2826f89744dded548d535736f27f0 SHA512 4550e53c21cb1191a4581e363fc9d0610da53f7898ca8320f0d3ef6711e76bdda2609c2df15dc94c45e28bff8de441f1227ec2da7ea827cb3c0405af4faa4736
diff --git a/media-libs/giflib/giflib-5.1.4.ebuild b/media-libs/giflib/giflib-5.1.4.ebuild
new file mode 100644 (file)
index 0000000..2e75ce6
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils libtool ltprune multilib-minimal
+
+DESCRIPTION="Library to handle, display and manipulate GIF images"
+HOMEPAGE="https://sourceforge.net/projects/giflib/"
+SRC_URI="mirror://sourceforge/giflib/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/7"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-text/xmlto )"
+
+src_prepare() {
+       default
+       elibtoolize
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               # No need for xmlto as they ship generated files.
+               ac_cv_prog_have_xmlto=no
+
+               $(use_enable static-libs static)
+       )
+
+       ECONF_SOURCE="${S}" \
+       econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+       default
+
+       if use doc && multilib_is_native_abi; then
+               emake -C doc
+       fi
+}
+
+multilib_src_install() {
+       default
+
+       # for static libs the .la file is required if built with +X
+       use static-libs || prune_libtool_files --all
+
+       if use doc && multilib_is_native_abi; then
+               docinto html
+               dodoc doc/*.html
+       fi
+}
+
+multilib_src_install_all() {
+       doman doc/*.1
+       docinto
+       dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+       if use doc; then
+               dodoc doc/*.txt
+               docinto html
+               dodoc -r doc/whatsinagif
+       fi
+}