dev-python/nbdime: Remove old
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 20:44:51 +0000 (21:44 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 20:44:51 +0000 (21:44 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/nbdime/Manifest
dev-python/nbdime/nbdime-0.1.2.ebuild [deleted file]

index 30d1e1514f2f09b9fcac81f25cbe70a50387907a..4eb4ff2033279b7d2937bcbf2a71879aa7225e53 100644 (file)
@@ -1,2 +1 @@
-DIST nbdime-0.1.2.tar.gz 3864624 BLAKE2B dbf51b7eb07d08870fe1c629aa294b784fd95c0d547de3a4ea4fcf7da5ad6c490df3b61f3cb353723b3139137a54b534460c2a25a6480f7316b6fd17d742d661 SHA512 9f704645ef1e64b0da260841769068db6f6aba37f30b3c6506a1876af1276acb452ed78f66b9e6d7029f06ed9fabf01a1484b4b86055f27a451d623a7eda90cf
 DIST nbdime-0.2.0.tar.gz 4139079 BLAKE2B 1e6994009c8ac291272a297fe583f79123906c9e05ca2afd345c6e230e3c476259c4919e2161a049e46fa28f4490122c53d0a2bc94661683652d226a78fb39be SHA512 c156b706e1d6cc7885f987d746e91d7f0c2fa48885339fd79e778643382ab45e2e52565f45cc73b9a305c6f5177339e875f53ae46d73578443880a4c7522976d
diff --git a/dev-python/nbdime/nbdime-0.1.2.ebuild b/dev-python/nbdime/nbdime-0.1.2.ebuild
deleted file mode 100644 (file)
index 0d4e32f..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="Diff and merge of Jupyter Notebooks"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test webtools"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/nbformat[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       dev-python/colorama[${PYTHON_USEDEP}]
-       dev-python/requests[${PYTHON_USEDEP}]
-       www-servers/tornado[${PYTHON_USEDEP}]
-       webtools? ( net-libs/nodejs[npm] )
-       "
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/pytest-timeout[${PYTHON_USEDEP}]
-               dev-python/jsonschema[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/requests[${PYTHON_USEDEP}]
-       )
-       "
-# The package recommonmark is required to build the docs, not in portage yet.
-# Furthermore, backports.shutil_which is required for python2_7.
-
-python_configure_all() {
-       if ! use webtools; then
-               mydistutilsargs=( --skip-npm )
-       fi
-}
-
-python_test() {
-       # user.email and user.name are not configured in the sandbox.
-       git config --global user.email "you@example.com" || die
-       git config --global user.name "Your Name" || die
-
-       distutils_install_for_testing
-
-       py.test -l || die
-}