app-crypt/pinentry: Version bump to 0.9.6
authorKristian Fiskerstrand <k_f@gentoo.org>
Mon, 14 Sep 2015 21:44:04 +0000 (23:44 +0200)
committerKristian Fiskerstrand <k_f@gentoo.org>
Mon, 14 Sep 2015 21:44:04 +0000 (23:44 +0200)
Package-Manager: portage-2.2.20.1

app-crypt/pinentry/Manifest
app-crypt/pinentry/pinentry-0.9.6.ebuild [new file with mode: 0644]

index b4d26ceefb956b210a53b6d2712aebcfb60a47ec..4461fc86e9872d9ce977c80cc4197adbd930293b 100644 (file)
@@ -1,2 +1,3 @@
 DIST pinentry-0.9.0.tar.bz2 464272 SHA256 90045a07ab8e1a8e1ecf5d19b51691f195525e579fa5d71d7e92c120b05490ab SHA512 2cc53a5c3852edaf6e940228d9b43fe4709344eba5fe230b7afd22b2c0239d0b258917d75661d80590b2d61c6fe9dac8ad15a0b4a0a0e7fba90a9e1c07364edd WHIRLPOOL 3f77a8aa2d44c7206d877e31088ec927473441e61f06e788330545d75ac489e6e9d5bf0026b23d0824304dad54ce8e61c4571d186df7ad0edc2d644ca3af04ac
 DIST pinentry-0.9.5.tar.bz2 514677 SHA256 6a57fd3afc0d8aaa5599ffcb3ea4e7c42c113a181e8870122203ea018384688c SHA512 31a190cacf45fd3ff5128a6a1a9f317fb09850fd595d5985392ea306ed65fa9232e2203458a9989eaac3b6e9d07199e01557912051f00a9a395cd1db61b44c39 WHIRLPOOL 52e9664d7cf0e804bb14b9586a89aca4037d3324261ac8931ed26365c32ae038b45eca9b7b6637b46f9231ff2db6a9e0a96a611404e48659c7ba009b84c40727
+DIST pinentry-0.9.6.tar.bz2 432889 SHA256 2a1124e9097f24f866cab7982610677e222cea71be0a71a5566f223177e01e66 SHA512 c9f94e5ce5baf6779f6effc13f82c8c7f99d426dc232114fc4e11a8684eaefbaf4f60363db78cdb9f4c8e91ba7af40779ec1c5d7e01ee15b84c7de77ccf46e72 WHIRLPOOL 954d185ce60eeb28717dd5986c4bdfda0472944b99d52caa213919b4dd1368b2d2b4cff27bfc4158a0fd7f70f7f6549b3415de7ba33239ec9305a2e0e0bdcbc0
diff --git a/app-crypt/pinentry/pinentry-0.9.6.ebuild b/app-crypt/pinentry/pinentry-0.9.6.ebuild
new file mode 100644 (file)
index 0000000..5b80f26
--- /dev/null
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools qmake-utils multilib eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://gnupg.org/aegypten2/index.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="clipboard emacs gtk ncurses qt4 caps gnome-keyring static"
+
+RDEPEND="
+       >=dev-libs/libgpg-error-1.17
+       >=dev-libs/libassuan-2
+       app-eselect/eselect-pinentry
+       caps? ( sys-libs/libcap )
+       gtk? ( x11-libs/gtk+:2 )
+       ncurses? ( sys-libs/ncurses:0= )
+       qt4? ( >=dev-qt/qtgui-4.4.1:4 )
+       static? ( >=sys-libs/ncurses-5.7-r5:0=[static-libs,-gpm] )
+"
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       virtual/pkgconfig
+       gnome-keyring? ( app-crypt/libsecret )
+"
+REQUIRED_USE="
+       || ( ncurses gtk qt4 )
+       gtk? ( !static )
+       qt4? ( !static )
+       static? ( ncurses )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_prepare() {
+       epatch "${FILESDIR}/${PN}-0.8.2-ncurses.patch"
+       epatch "${FILESDIR}/${P}-build.patch"
+       eautoreconf
+}
+
+src_configure() {
+       use static && append-ldflags -static
+       [[ "$(gcc-major-version)" -ge 5 ]] && append-cxxflags -std=gnu++11
+
+       # Issues finding qt on multilib systems
+       export QTLIB="${QTDIR}/$(get_libdir)"
+
+       econf \
+               --enable-pinentry-tty \
+               $(use_enable emacs pinentry-emacs) \
+               $(use_enable gtk pinentry-gtk2) \
+               $(use_enable ncurses pinentry-curses) \
+               $(use_enable ncurses fallback-curses) \
+               $(use_enable qt4 pinentry-qt4) \
+               $(use qt4 && use_enable clipboard pinentry-qt4-clipboard) \
+               $(use_with caps libcap) \
+               $(use_enable gnome-keyring libsecret) \
+               $(use_enable gnome-keyring pinentry-gnome3) \
+               MOC="$(qt4_get_bindir)"/moc
+}
+
+src_install() {
+       default
+       rm -f "${ED}"/usr/bin/pinentry || die
+}
+
+pkg_postinst() {
+       if ! has_version 'app-crypt/pinentry' || has_version '<app-crypt/pinentry-0.7.3'; then
+               elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
+               elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
+               elog "The soft resource limit for memory locking specifies the limit an"
+               elog "unprivileged process may lock into memory. You can also use POSIX"
+               elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
+               elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
+               elog "your users."
+       fi
+       eselect pinentry update ifunset
+}
+
+pkg_postrm() {
+       eselect pinentry update ifunset
+}