app-vim/cream: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 15 Mar 2020 08:03:50 +0000 (11:03 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 15 Mar 2020 08:03:50 +0000 (11:03 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-vim/cream/Manifest [deleted file]
app-vim/cream/cream-0.43.ebuild [deleted file]
app-vim/cream/files/cream-0.30-ebuilds.patch [deleted file]
app-vim/cream/files/enhancedcommentify-2.1-extra-ft-support.patch [deleted file]
app-vim/cream/files/enhancedcommentify-2.1-gentooisms.patch [deleted file]
app-vim/cream/metadata.xml [deleted file]

diff --git a/app-vim/cream/Manifest b/app-vim/cream/Manifest
deleted file mode 100644 (file)
index d767bea..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST cream-0.43.tar.gz 785889 BLAKE2B 39231309c5382e26587a602d8185e40012f7b850ed6dcd1372eaed65e05e6a97ed7222bdc29666255f345e99ff696901da02acf7814ff784b6545d06f970866a SHA512 6e6c139bcb5f1ed8cb9718f2c1453a69453c87f2588b6074264f94877dd5b7f78842f5a7c45df693effc2249020e5fa61a88ab5d4e3e13806e2674f1f57dccb7
-DIST cream-spell-dict-eng_2.0.2.zip 1778434 BLAKE2B c4f73ba51cf1371faec1d3aaae44d55a38ef11d351bd66cd51514067feea78b27f381cb7184be8cd26d74e863634ea9e2f4841ef29b98693e92874cee9ab680c SHA512 72ea2c4d72fc39aa80d9f47762f42ec3fcc4251cc27a9dc62a8b8f8f4b66340df7c15afd603a0e4a12805770606c09e462be548f5203feba76badefa27321b1d
-DIST cream-spell-dict-fre_2.1.zip 872841 BLAKE2B 0711e0780c8a9b77f8bea9deda47bef3417ebea91f672a5146a0644c2f2fd70f4ccbc032802a62bd60b908d1c289a2acc46bf80115a3c37a5ef113f509319773 SHA512 d34773e3ec2bd905a669175680f91146ead8dc0a7d3de8fa668c56e550eed23ac6c8678b2e7b3c642b756d6eba97b815494395c07b3f28cb54e3a01cf8f5b1a0
-DIST cream-spell-dict-ger_2.0.1.zip 894848 BLAKE2B 0018d95b887ee48b7f36b9a7a90413a3a45c4daf6f939ec428670f54e690206e447813c0fff3048106d816960b6be0ce7153362dd0305fc2276fab1b58269efd SHA512 1fb1a797bfbcd0516d8124daf1256b27a356ef3eb58887c2a55fc8537f211faa60dcba713935b2fa5595ebf6bba07a1463819060018f725e5cd0952b978a342a
-DIST cream-spell-dict-spa_3.0.zip 1710280 BLAKE2B 44039b8ee664fe9c9664bb60af60e6b9687dd51989a2452ee3bc7afca4fa6d7f124221aca7d8578c27b462b3d660417a7c518ba4bbff64fa76125cecb29f0fd9 SHA512 27de9d920afe191ae4e7d5267b5ad6fb14a6e4185d474c09d17af1eb45f926dab2d4696080cee25d1591bf0b588234a20778e9b1485927dfffa8595b19e247d2
diff --git a/app-vim/cream/cream-0.43.ebuild b/app-vim/cream/cream-0.43.ebuild
deleted file mode 100644 (file)
index a744140..0000000
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit vim-plugin eutils fdo-mime
-
-DESCRIPTION="An easy-to-use configuration of the GVim text editor"
-HOMEPAGE="http://cream.sourceforge.net"
-
-DICT_EN="eng_2.0.2"
-DICT_FR="fre_2.1"
-DICT_ES="spa_3.0"
-DICT_DE="ger_2.0.1"
-
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
-       l10n_de? ( http://cream.sourceforge.net/cream-spell-dict-${DICT_DE}.zip )
-       l10n_en? ( http://cream.sourceforge.net/cream-spell-dict-${DICT_EN}.zip )
-       l10n_es? ( http://cream.sourceforge.net/cream-spell-dict-${DICT_ES}.zip )
-       l10n_fr? ( http://cream.sourceforge.net/cream-spell-dict-${DICT_FR}.zip )"
-
-IUSE="l10n_de l10n_en l10n_fr l10n_es"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ia64 ~mips ppc sparc x86"
-
-DEPEND="
-       >=app-editors/gvim-7.0
-       app-arch/unzip"
-RDEPEND="
-       >=app-editors/gvim-7.0
-       dev-util/ctags"
-
-VIM_PLUGIN_HELPTEXT=\
-"Cream is completely independent from the rest of your Vim/GVim setup.
-To launch GVim in Cream mode, use this wrapper script:
-\    % cream [filename...]
-
-Cream's documentation has been installed in ${ROOT}usr/share/doc/${PF}
-In particular, you may want to read:
-
-\ - the Cream features list:
-file://${ROOT}usr/share/doc/${PF}/html/features.html
-
-\ - the Cream shortcuts list:
-file://${ROOT}usr/share/doc/${PF}/html/keyboardshortcuts.html
-
-\ - the Cream FAQ:
-file://${ROOT}usr/share/doc/${PF}/html/faq.html"
-
-# Utility function to rename a Vim help file and its links/anchors:
-#   prefix_help_file prefix file [pattern ...]
-prefix_help_file() {
-       local prefix="${1}" ; shift
-       local helpfile="${1}" ; shift
-       while [[ -n "${1}" ]] ; do
-               sed -i "s:\([*|]\)\(${1}[*|]\):\1${prefix}-\2:g" "${helpfile}" \
-                       || die "Failed to sed \"${1}\" on \"${helpfile}\""
-               shift
-       done
-       mv "${helpfile}" "${helpfile%/*}/${prefix}-${helpfile##*/}" \
-               || die "Failed to rename \"${helpfile}\""
-}
-
-pkg_setup() {
-       elog "Cream comes with several dictionaries for spell checking. In"
-       elog "all cases, at least a small English dictionary will be installed."
-       elog
-       elog "To specify which optional dictionaries are installed, set the"
-       elog "L10N variable in /etc/portage/make.conf. For example, to install full"
-       elog "English and French dictionaries, use:"
-       elog "    L10N=\"en fr\""
-       elog
-       elog "Available dictionaries are:"
-       for dict in "English en" "French fr" "German de" "Spanish es" ; do
-               elog "    ${dict% *} \t(${dict#* }) $(usex l10n_${dict#* } \
-                       "(Will be installed)" "(Will not be installed)")"
-       done
-       elog
-}
-
-src_unpack() {
-       mkdir -p "${S}"/spelldicts
-
-       # install spell dictionaries into ${S}/spelldicts
-       local my_a
-       for my_a in ${A} ; do
-               if [ -z ${my_a/*spell-dict*/} ] ; then
-                       cd "${S}"/spelldicts
-                       unpack ${my_a}
-               else
-                       cd "${WORKDIR}"
-                       unpack ${my_a}
-               fi
-       done
-}
-
-src_prepare() {
-       # change installation path + fix the wrapper command (disable plugins)
-       cat > cream <<-EOF
-       #!/bin/sh
-       gvim --servername CREAM --noplugin -U NONE -u "\\\$VIM/cream/creamrc" "\$@"
-       EOF
-
-       sed -i "/let \$CREAM/s:VIMRUNTIME:VIM:" creamrc || die
-
-       # make taglist ebuild aware, bug #66052
-       epatch "${FILESDIR}"/${PN}-0.30-ebuilds.patch
-
-       # more filetypes for EnhancedCommentify, including the Gentoo ones
-       epatch "${FILESDIR}"/enhancedcommentify-2.1-gentooisms.patch
-       epatch "${FILESDIR}"/enhancedcommentify-2.1-extra-ft-support.patch
-
-       # rename vim help files to avoid conflicts with other vim packages
-       prefix_help_file cream help/EnhancedCommentify.txt \
-               'EnhancedCommentify' 'EnhComm-[a-zA-Z]\+'
-
-}
-
-src_install() {
-       # install launcher and menu entry
-       dobin cream
-       domenu cream.desktop
-       doicon cream.svg cream.png
-
-       # install shared vim files
-       insinto /usr/share/vim/cream
-       doins *.vim creamrc
-       local dir
-       for dir in addons bitmaps filetypes lang ; do
-               insinto /usr/share/vim/cream/${dir}
-               doins ${dir}/*
-       done
-
-       if [[ -n ${L10N} ]] ; then
-               insinto /usr/share/vim/cream/spelldicts
-               doins spelldicts/*
-       fi
-
-       insinto /usr/share/vim/vimfiles/doc
-       doins help/*.txt
-
-       # install docs
-       dodoc docs/{CHANGELOG,DEVELOPER,KEYBOARD,PressRelease,README,RELEASE}.txt
-       dohtml docs-html/*
-       # html doc may be opened from Cream GUI
-       dosym ../../doc/${PF}/html /usr/share/vim/cream/docs-html
-}
-
-pkg_postinst() {
-       fdo-mime_desktop_database_update
-       vim-plugin_pkg_postinst
-}
-
-pkg_postrm() {
-       fdo-mime_desktop_database_update
-       vim-plugin_pkg_postrm
-}
diff --git a/app-vim/cream/files/cream-0.30-ebuilds.patch b/app-vim/cream/files/cream-0.30-ebuilds.patch
deleted file mode 100644 (file)
index 30e3103..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- cream-0.30/taglist.vim.orig        2004-10-02 00:12:58.400215576 +0100
-+++ cream-0.30/taglist.vim     2004-10-02 00:26:28.535056360 +0100
-@@ -205,6 +205,9 @@
- let s:tlist_def_cobol_settings = 'cobol;d:data;f:file;g:group;p:paragraph;' .
-                                \ 'P:program;s:section'
-+" ebuilds
-+let s:tlist_def_ebuild_settings = 'sh;f:function'
-+
- " eiffel language
- let s:tlist_def_eiffel_settings = 'eiffel;c:class;f:feature'
diff --git a/app-vim/cream/files/enhancedcommentify-2.1-extra-ft-support.patch b/app-vim/cream/files/enhancedcommentify-2.1-extra-ft-support.patch
deleted file mode 100644 (file)
index 597518a..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- plugin/EnhancedCommentify.vim.orig 2005-03-01 02:28:23.409962824 -0500
-+++ plugin/EnhancedCommentify.vim      2005-03-01 02:29:45.695453528 -0500
-@@ -740,7 +740,9 @@
-               \ 'psf\|ptcap\|r\|radiance\|ratpoison\|readline\remind\|'.
-               \ 'ruby\|screen\|sed\|sm\|snnsnet\|snnspat\|snnsres\|spec\|'.
-               \ 'squid\|terminfo\|tidy\|tli\|tsscl\|vgrindefs\|vrml\|'.
--              \ 'wget\|wml\|xf86conf\|xmath\)$'
-+              \ 'wget\|wml\|xf86conf\|xmath\|fstab\|apache\|resolv\|sudoers\|'.
-+              \ 'ntp\|mailcap\|ssh_config\|sshdconfig\|mplayerconf\|desktop\|'.
-+              \ 'gkrellmrc\|pf\|ipfilter\|grub\|fluxbox\)$'
-       let b:ECcommentOpen = '#'
-       let b:ECcommentClose = ''
-     elseif fileType =~ 'gentoo'
diff --git a/app-vim/cream/files/enhancedcommentify-2.1-gentooisms.patch b/app-vim/cream/files/enhancedcommentify-2.1-gentooisms.patch
deleted file mode 100644 (file)
index 9e45142..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- plugin/EnhancedCommentify.vim.orig 2005-01-27 00:20:00.049461056 -0500
-+++ plugin/EnhancedCommentify.vim      2005-01-27 00:17:57.617073608 -0500
-@@ -628,6 +628,10 @@
-     " letter.
-     if match(synFiletype, '\l\+\u') == 0
-       let ft = substitute(synFiletype, '^\(\l\+\)\u.*$', '\1', "")
-+    " work-around for gentoo-syntax stuff ; won't work with the above
-+    " case, since all the identifiers start with a capital 'G'
-+    elseif synFiletype =~ "GentooPackage*"
-+      let ft = "gentoo"
-     endif
-     if ft == ""
-@@ -739,6 +743,9 @@
-               \ 'wget\|wml\|xf86conf\|xmath\)$'
-       let b:ECcommentOpen = '#'
-       let b:ECcommentClose = ''
-+    elseif fileType =~ 'gentoo'
-+      let b:ECcommentOpen = '#'
-+      let b:ECcommentClose = ''
-     elseif fileType == 'webmacro'
-       let b:ECcommentOpen = '##'
-       let b:ECcommentClose = ''
diff --git a/app-vim/cream/metadata.xml b/app-vim/cream/metadata.xml
deleted file mode 100644 (file)
index a882b88..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="project">
-               <email>vim@gentoo.org</email>
-               <name>Gentoo Vim Project</name>
-       </maintainer>
-       <upstream>
-               <remote-id type="sourceforge">cream</remote-id>
-       </upstream>
-</pkgmetadata>