app-doc/lapack-docs: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 10:13:15 +0000 (12:13 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 10:13:15 +0000 (12:13 +0200)
Closes: https://bugs.gentoo.org/697388
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
app-doc/lapack-docs/lapack-docs-3.1.1.ebuild

index 9d017eec92d02f5d8307db5c551f2b638dbd30e7..0789a1733c2011b9ff89ea22093722b860038ff2 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 DESCRIPTION="Documentation reference and man pages for lapack implementations"
 HOMEPAGE="http://www.netlib.org/lapack"
@@ -16,16 +16,16 @@ IUSE=""
 S="${WORKDIR}/lapack-${PV}/manpages"
 
 src_install() {
-       # These belong to the blas-docs
-       rm -f man/manl/{lsame,xerbla}.*
+       # These belong to blas-docs
+       rm -f man/manl/{lsame,xerbla}.* || die
 
-       # rename because doman do not yet understand manl files
-       # Not all systems have the rename command, like say FreeBSD
-       local f= t=
+       # rename because doman does not yet understand manl files
+       local f t
        for f in man/manl/*.l; do
                t="${f%%.l}.n"
-               mv "${f}" "${t}"
+               mv "${f}" "${t}" || die
        done
-       doman man/manl/* || die "doman failed"
-       dodoc README "${DISTDIR}"/lapackqref.ps || die "dodoc failed"
+
+       doman man/manl/*
+       dodoc README "${DISTDIR}"/lapackqref.ps
 }