games-sports/ski: [QA] Add missing python metadata variables
authorDavid Seifert <soap@gentoo.org>
Sun, 23 Apr 2017 09:07:40 +0000 (11:07 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 23 Apr 2017 11:24:10 +0000 (13:24 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

games-sports/ski/ski-6.8.ebuild
games-sports/ski/ski-6.9-r1.ebuild
games-sports/ski/ski-6.9.ebuild

index 2f6f37632bdab8b613ccbd550897a0a7d33e4328..fdb1608a108ed193c3a667c9d127ecfc210dacba 100644 (file)
@@ -1,8 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 )
+
 inherit python-single-r1 games
 
 DESCRIPTION="A simple text-mode skiing game"
@@ -13,9 +15,10 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 ppc x86"
 IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
-DEPEND=""
-RDEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
 
 pkg_setup() {
        games_pkg_setup
index e61049424ece18f4f2662f7f0ca49e94836892f5..a18d0d0158cf64aff12598231bbe50fa643a56c5 100644 (file)
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
+
 PYTHON_COMPAT=( python2_7 )
+
 inherit eutils python-single-r1
 
 DESCRIPTION="A simple text-mode skiing game"
@@ -13,13 +15,10 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
 IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
-DEPEND=""
-RDEPEND=""
-
-pkg_setup() {
-       python-single-r1_pkg_setup
-}
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
 
 src_install() {
        dobin ski
index 6159ddd70bb4eaa69d09bb3667ccfc9ff05fdac4..146c838b59fda01239b733bb1e219a33a3beebc7 100644 (file)
@@ -1,8 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 )
+
 inherit python-single-r1 games
 
 DESCRIPTION="A simple text-mode skiing game"
@@ -13,9 +15,10 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 ~ppc x86"
 IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
-DEPEND=""
-RDEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
 
 pkg_setup() {
        games_pkg_setup