Added missing files, closes bug#158504, thanks to Lars Weiler.
authorAlon Bar-Lev <alonbl@gentoo.org>
Thu, 21 Dec 2006 21:03:05 +0000 (21:03 +0000)
committerAlon Bar-Lev <alonbl@gentoo.org>
Thu, 21 Dec 2006 21:03:05 +0000 (21:03 +0000)
Some cleanups.
Package-Manager: portage-2.1.1-r2

sys-power/hibernate-script/ChangeLog
sys-power/hibernate-script/files/digest-hibernate-script-1.94-r1 [new file with mode: 0644]
sys-power/hibernate-script/hibernate-script-1.94-r1.ebuild [new file with mode: 0644]

index c95ebe92d49685f65b6252bff8b62a51618e62af..e941ff659e84b01715d707706620537a63bc459e 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for sys-power/hibernate-script
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.41 2006/12/17 21:24:10 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.42 2006/12/21 21:03:05 alonbl Exp $
+
+*hibernate-script-1.94-r1 (21 Dec 2006)
+
+  21 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org>
+  -files/hibernate-script-1.12-gentoo.patch,
+  -files/hibernate-script-1.12-misc.patch, -hibernate-script-1.12-r1.ebuild,
+  -hibernate-script-1.94.ebuild, +hibernate-script-1.94-r1.ebuild:
+  Added missing files, closes bug#158504, thanks to Lars Weiler.
+  Some cleanups.
 
 *hibernate-script-1.94 (17 Dec 2006)
 
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.94-r1 b/sys-power/hibernate-script/files/digest-hibernate-script-1.94-r1
new file mode 100644 (file)
index 0000000..8ee1180
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 8f927bb983870516901aebd8718f08ee hibernate-script-1.94-patches-2.tar.bz2 3225
+RMD160 c12154ac46444c521a6fd902cc9d80d455ee1641 hibernate-script-1.94-patches-2.tar.bz2 3225
+SHA256 a784331f7438d93b9895630086c02fda90fea00b30d8bc2dafec3b5080c5bd28 hibernate-script-1.94-patches-2.tar.bz2 3225
+MD5 f8826d4c96e320902382f29c91694c04 hibernate-script-1.94.tar.gz 72928
+RMD160 31d105c08bf183e3bc770543e0ae01678798859b hibernate-script-1.94.tar.gz 72928
+SHA256 57ad0de0cce263c76303a5c7116550f19aaec540c6743e0b5bcd5d0cb68d2fe2 hibernate-script-1.94.tar.gz 72928
diff --git a/sys-power/hibernate-script/hibernate-script-1.94-r1.ebuild b/sys-power/hibernate-script/hibernate-script-1.94-r1.ebuild
new file mode 100644 (file)
index 0000000..cf99d0b
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.94-r1.ebuild,v 1.1 2006/12/21 21:03:05 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="2"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz
+       mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       rm -f "${S}"/scriptlets.d/swsusp2_15
+       epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+       BASE_DIR="${D}" PREFIX=/usr MAN_DIR="${D}"/usr/share/man \
+               "${S}"/install.sh || die "Install failed"
+
+       # hibernate-ram will default to using ram.conf
+       dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+       newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+       # other ebuilds can install scriplets to this dir
+       keepdir /etc/hibernate/scriptlets.d/
+
+       if use vim; then
+               insinto /usr/share/vim/vimfiles
+               doins hibernate.vim
+       fi
+
+       dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+       if use logrotate; then
+               insinto /etc/logrotate.d
+               newins "${S}"/logrotate.d-hibernate-script hibernate-script
+       fi
+}
+
+pkg_postinst() {
+       elog
+       elog "You should run the following command to invalidate"
+       elog "suspend images on a clean boot."
+       elog
+       elog "  # rc-update add hibernate-cleanup boot"
+       elog
+       elog "See /usr/share/doc/${PF}/README.gz for further details."
+       elog
+       elog "Please note that you will need to manually emerge any utilities"
+       elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+       elog "should you wish to use them."
+       elog
+       elog "Starting with hibernate-script-1.90 the configuration files have"
+       elog "been reordered and split into method specific files. Make sure you"
+       elog "update your /etc/hibernate/ configuration files accordingly."
+       elog
+}