dev-java/ant-core-1.9.13: bump (bug #571110)
authorMiroslav Šulc <fordfrog@gentoo.org>
Mon, 21 Jan 2019 09:24:49 +0000 (10:24 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Mon, 21 Jan 2019 10:29:22 +0000 (11:29 +0100)
Package-Manager: Portage-2.3.57, Repoman-2.3.12
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
dev-java/ant-core/Manifest
dev-java/ant-core/ant-core-1.9.13.ebuild [new file with mode: 0644]

index bb1cab123ebcdf494f4cc5259a963b8f047ebe1d..407511ed5b54c9237522011dd8b2e2212c9ae8b1 100644 (file)
@@ -1,2 +1,4 @@
+DIST ant-1.9.13-gentoo.tar.bz2 7189 BLAKE2B 65bc50bb401cd9ad48763acfa1208e1d52a87bf4df3591dfcdb0f2ded2e7e70c9a42199b0160c7bc233dff83f6889b2ce5fd5aa09a76973f7ea03e963bc9e73e SHA512 0c04116399fa4e83e3283c6d2a69b562aeac0eacda44eb6ce0210e2b0846f48c72975dcfc17315e072226adeb6c1438cd7f83189d4e2974a8a90ec7c6534c898
 DIST ant-1.9.2-gentoo.tar.bz2 14884 BLAKE2B d67b14350ed135c656313a018c25dbd915838bb2f34c666d05347f9127ccee7c1552d319d195af24c748cc36aa1ec1c8dcc2a826da4cffcf05ddb08b2f6c5021 SHA512 2bb84e71d1f07fa9341e674164ee680875381a0a52f5309a1a6f4092df691bf9a83955e4b1a9bcc907fbb2f4d4427afa192bffb8909314b8e519f0b76ebf5b7f
+DIST apache-ant-1.9.13-src.tar.bz2 3954912 BLAKE2B 1ec249bb33f54fde80ba8a17248755e7412eb3415b14a03f0558bcc220c3eb47dc88128d435e59f10118f74c31eab8eea83f5d5db09640e1a5aaf08bac1490c1 SHA512 27cd4566df35a09873f32f897ea47c55ad3940f48440b52ce9838e5fcd9e8ca55b27151a25597f21c430cd2921e3b2b6b105962d0d40294a1eb06ed689b05810
 DIST apache-ant-1.9.2-src.tar.bz2 3402876 BLAKE2B c695fdfed67672716619db459f6644aad70876fa546523114500fa4007998b6b7b0856143365edf58b843fba35f0a46827e7a07b8cc730eebe4b9f7d8e87bf25 SHA512 44d37e7b6c22741293ae9d6f331bc5a21a807206d22082b111af95a0d1820b62f806c5ee8d8ac638566b86990ec802bc948066c4ac9da27262659b24545fc629
diff --git a/dev-java/ant-core/ant-core-1.9.13.ebuild b/dev-java/ant-core/ant-core-1.9.13.ebuild
new file mode 100644 (file)
index 0000000..55b6cd4
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Don't depend on itself.
+JAVA_ANT_DISABLE_ANT_CORE_DEP="true"
+
+# Rewriting build.xml files for the testcases has no use at the moment.
+JAVA_PKG_BSFIX_ALL="no"
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2 prefix eapi7-ver
+
+MY_P="apache-ant-${PV}"
+
+DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files"
+HOMEPAGE="https://ant.apache.org/"
+SRC_URI="https://archive.apache.org/dist/ant/source/${MY_P}-src.tar.bz2
+       https://dev.gentoo.org/~fordfrog/distfiles/ant-${PV}-gentoo.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND=">=virtual/jdk-1.8:*
+       !dev-java/ant-tasks
+       !dev-java/ant-optional"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="test"
+
+src_prepare() {
+       epatch "${WORKDIR}/${PV}-build.patch"
+       epatch "${WORKDIR}/${PV}-launch.patch"
+
+       eprefixify "${S}/src/script/ant"
+
+       # Fixes bug 556008.
+       java-ant_xml-rewrite -f build.xml \
+               -c -e javadoc \
+               -a failonerror \
+               -v "false"
+
+       # See bug #196080 for more details.
+       java-ant_bsfix_one build.xml
+       java-pkg-2_src_prepare
+}
+
+src_compile() {
+       export ANT_HOME=""
+
+       local bsyscp
+
+       # This ensures that when building ant with bootstrapped ant,
+       # only the source is used for resolving references, and not
+       # the classes in bootstrapped ant but jikes in kaffe has issues with this...
+       if ! java-pkg_current-vm-matches kaffe; then
+               bsyscp="-Dbuild.sysclasspath=ignore"
+       fi
+
+       CLASSPATH="$(java-config -t)" ./build.sh ${bsyscp} jars dist-internal \
+               $(use_doc javadocs) || die "build failed"
+}
+
+src_install() {
+       dodir /usr/share/ant/lib
+
+       for jar in ant.jar ant-bootstrap.jar ant-launcher.jar ; do
+               java-pkg_dojar build/lib/${jar}
+               dosym ../../${PN}/lib/${jar} /usr/share/ant/lib/${jar}
+       done
+
+       dobin src/script/ant
+
+       dodir /usr/share/${PN}/bin
+       for each in antRun antRun.pl runant.pl runant.py complete-ant-cmd.pl ; do
+               dobin "${S}/src/script/${each}"
+               dosym ../../../bin/${each} /usr/share/${PN}/bin/${each}
+       done
+       dosym ../${PN}/bin /usr/share/ant/bin
+
+       insinto /usr/share/${PN}
+       doins -r dist/etc
+       dosym ../${PN}/etc /usr/share/ant/etc
+
+       echo "ANT_HOME=\"${EPREFIX}/usr/share/ant\"" > "${T}/20ant"
+       doenvd "${T}/20ant"
+
+       dodoc NOTICE README WHATSNEW KEYS
+
+       if use doc; then
+               dohtml -r manual/*
+               java-pkg_dojavadoc --symlink manual/api build/javadocs
+       fi
+
+       use source && java-pkg_dosrc src/main/*
+}
+
+pkg_postinst() {
+       if [[ -n ${REPLACING_VERSIONS} ]]; then
+               if _ver_compare ${REPLACING_VERSIONS} 1.7.0 -eq 1; then
+                       elog "The way of packaging ant in Gentoo has changed significantly since"
+                       elog "the 1.7.0 version, For more information, please see:"
+                       elog "https://www.gentoo.org/proj/en/java/ant-guide.xml"
+               fi
+
+               if _ver_compare ${REPLACING_VERSIONS} 1.7.1 -eq 1; then
+                       elog "Since 1.7.1, the ant-tasks meta-ebuild has been removed and its USE"
+                       elog "flags have been moved to dev-java/ant."
+               fi
+       fi
+}