dev-python/PyGithub: Bump to 1.44
authorMichał Górny <mgorny@gentoo.org>
Sun, 20 Oct 2019 06:39:22 +0000 (08:39 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 20 Oct 2019 07:16:07 +0000 (09:16 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/PyGithub/Manifest
dev-python/PyGithub/PyGithub-1.44.ebuild [new file with mode: 0644]

index 42af60bbf085a6f634fc5d15544076f468a357b6..695511bc51d64d6ac7aabe3d6930234461673f56 100644 (file)
@@ -1 +1,2 @@
 DIST PyGithub-1.43.8.gh.tar.gz 2842219 BLAKE2B 7711885beb4cb855ea5a5755abe881f7ae7825feb76cb0ab30aa9ba4a2530440d2816439c43da23a42f134286fa0806875d075920776960f04cdd21131bcf700 SHA512 dc58166ebb27f855ed4f32448029abe7e53b8050d8d99029d460f2dd94180ca8bcef68a75469293abd021f70cc3c67c32061e6439db1b3f1dc77af464c658bb6
+DIST PyGithub-1.44.gh.tar.gz 2855748 BLAKE2B f728562617632f99d5b8a141e7b8eb7527812388e71c7f6dcc55fbec2b0da5ab3882985d4e815fe18affa662351942ba2223eda3ae68bc1cf550c2cbc2bee7f9 SHA512 26aa86822fb8c3ca8a8a0e8d5cd9bf9457cab8a4aa006fa195bb4922867627b5516adbee19cbf5c30d24de8266b496741ae7f4dd8c7cc0494044e6cd585402b1
diff --git a/dev-python/PyGithub/PyGithub-1.44.ebuild b/dev-python/PyGithub/PyGithub-1.44.ebuild
new file mode 100644 (file)
index 0000000..4841760
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="https://github.com/PyGithub/PyGithub/"
+# Use github since pypi is missing test data
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/deprecated[${PYTHON_USEDEP}]
+       dev-python/pyjwt[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/cryptography[${PYTHON_USEDEP}]
+               >=dev-python/httpretty-0.9.6[${PYTHON_USEDEP}]
+       )"
+
+python_prepare_all() {
+       # tests requiring network access
+       sed -i -e 's:testDecodeJson:_&:' tests/Issue142.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       "${EPYTHON}" -m unittest -v tests.AllTests || die "Tests fail with ${EPYTHON}"
+}