dev-python/pylru: initial import
authorAlexey Shvetsov <alexxy@gentoo.org>
Tue, 11 Feb 2020 09:47:26 +0000 (12:47 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Tue, 11 Feb 2020 11:41:34 +0000 (14:41 +0300)
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
dev-python/pylru/Manifest [new file with mode: 0644]
dev-python/pylru/metadata.xml [new file with mode: 0644]
dev-python/pylru/pylru-1.2.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/pylru/Manifest b/dev-python/pylru/Manifest
new file mode 100644 (file)
index 0000000..80df80b
--- /dev/null
@@ -0,0 +1 @@
+DIST pylru-1.2.0.tar.gz 18533 BLAKE2B 6cebc3ecc91050bdf3c8f2721a7ee1768fb48692567eb2e8603e0d28fbfd01634087bf8fda0c0c3f8c9af377195623d2689f9eb59a3ad781ccfc5f58b362a734 SHA512 d4b247cb3740c2f94f4f41bd9affbb87db4e2ec8ff566978d130d08fee9df6109c13b64f22536903bf8be3ea60d4b105dd969d1156a279115b6bfedb817cdbf5
diff --git a/dev-python/pylru/metadata.xml b/dev-python/pylru/metadata.xml
new file mode 100644 (file)
index 0000000..c76e89a
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>alexxy@gentoo.org</email>
+               <name>Alexey Shvetsov</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+               <name>Python</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="pypi">pylru</remote-id>
+               <remote-id type="github">jlhutch/pylru</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylru/pylru-1.2.0.ebuild b/dev-python/pylru/pylru-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..bcc8466
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A least recently used (LRU) cache for Python"
+HOMEPAGE="https://github.com/jlhutch/pylru"
+LICENSE="GPL-2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+BDEPEND=""
+RDEPEND=""