dev-python/django-otp: Require sqlite for tests
authorMichał Górny <mgorny@gentoo.org>
Tue, 19 May 2020 11:29:41 +0000 (13:29 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 19 May 2020 11:29:41 +0000 (13:29 +0200)
Closes: https://bugs.gentoo.org/723612
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/django-otp/django-otp-0.9.1.ebuild

index 4bbf7d96389b05ea82266c8d11b2d3f361ecef81..cb3c87c6043b9bf9cbeca144a065d9eb0a6748cd 100644 (file)
@@ -21,7 +21,11 @@ RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/django-1.11[${PYTHON_USEDEP}]"
-BDEPEND="test? ( ${RDEPEND} )"
+BDEPEND="
+       test? (
+               $(python_gen_impl_dep sqlite)
+               ${RDEPEND}
+       )"
 
 python_test() {
        local -x PYTHONPATH=test:${PYTHONPATH}