sys-apps/pkgcore: Add missing any-of dep on snakeoil
authorMichał Górny <mgorny@gentoo.org>
Sat, 14 Dec 2019 17:33:33 +0000 (18:33 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 14 Dec 2019 17:49:04 +0000 (18:49 +0100)
Closes: https://bugs.gentoo.org/702916
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-apps/pkgcore/pkgcore-0.10.8.ebuild

index 48263e63a067122dd0083dcbc0ca1c5cbda27670..7351db9305d088d334450e5f20689bdf41b2dba6 100644 (file)
@@ -32,6 +32,7 @@ DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        doc? ( $(python_gen_any_dep '
                dev-python/setuptools[${PYTHON_USEDEP}]
+               dev-python/snakeoil[${PYTHON_USEDEP}]
                dev-python/docutils[${PYTHON_USEDEP}]
                dev-python/sphinx[${PYTHON_USEDEP}]
        ') )
@@ -43,6 +44,7 @@ DEPEND="${RDEPEND}
 
 python_check_deps() {
        has_version "dev-python/setuptools[${PYTHON_USEDEP}]" || return 1
+       has_version "dev-python/snakeoil[${PYTHON_USEDEP}]" || return 1
        if use doc; then
                has_version "dev-python/docutils[${PYTHON_USEDEP}]" &&
                has_version "dev-python/sphinx[${PYTHON_USEDEP}]"