www-apps/liquid_feedback_frontend: EAPI 7
authorAlfredo Tupone <tupone@gentoo.org>
Mon, 25 May 2020 05:46:32 +0000 (07:46 +0200)
committerAlfredo Tupone <tupone@gentoo.org>
Mon, 25 May 2020 05:46:32 +0000 (07:46 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
www-apps/liquid_feedback_frontend/liquid_feedback_frontend-2.2.7.ebuild
www-apps/liquid_feedback_frontend/liquid_feedback_frontend-3.0.6.ebuild

index a482ccbabca767b8705de44cc2d73199fe6d6dec..1c9f8c97b1d7aacf729933b93c8c036a7cf1ce1c 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 inherit estack eutils toolchain-funcs
 
@@ -35,6 +35,7 @@ src_prepare() {
                        rm -f locale/help/*.${lang}.txt
                fi
        done
+       default
 }
 
 src_compile() {
@@ -59,7 +60,7 @@ src_install() {
 
        insinto /etc/${PN}
        doins "${FILESDIR}"/myconfig.lua config/*
-       dosym /etc/${PN} /var/lib/${PN}/config
+       dosym ../../../etc/${PN} /var/lib/${PN}/config
 
        insinto /usr/share/${PN}
        doins "${FILESDIR}"/lqfb-apache.conf
index 79a779ceea4f5fbdfbdbe4ff0ae02fb7f0528082..6cac5a55db6991d995be5224ffabbc8076c43f67 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 inherit eutils toolchain-funcs
 
@@ -37,7 +37,7 @@ src_install() {
 
        insinto /etc/${PN}
        doins "${FILESDIR}"/myconfig.lua config/*
-       dosym /etc/${PN} /var/lib/${PN}/config
+       dosym ../../../etc/${PN} /var/lib/${PN}/config
 
        insinto /usr/share/${PN}
        doins "${FILESDIR}"/lqfb-apache.conf