app-dicts/migemo-dict: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 18 Oct 2019 12:18:47 +0000 (14:18 +0200)
committerDavid Seifert <soap@gentoo.org>
Fri, 18 Oct 2019 12:18:47 +0000 (14:18 +0200)
Closes: https://bugs.gentoo.org/697406
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
app-dicts/migemo-dict/migemo-dict-200812.ebuild

index 8245e4067d6ed627df8e15c7bcc972934f41925a..8a8c03b79a4d392386bef4e59b7adbf0af591e95 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-IUSE="unicode"
+EAPI=7
 
 DESCRIPTION="Dictionary files for the Migemo and C/Migemo"
 HOMEPAGE="http://openlab.ring.gr.jp/skk/dic.html"
@@ -12,18 +10,17 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
 LICENSE="GPL-2"
 KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
 SLOT="0"
+IUSE="unicode"
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       if use unicode ; then
-               iconv -f euc-jp -t utf-8 migemo-dict > "${T}/migemo-dict"
+src_configure() {
+       if use unicode; then
+               iconv -f euc-jp -t utf-8 migemo-dict > "${T}"/migemo-dict || die
        else
-               cp migemo-dict "${T}/migemo-dict"
+               cp migemo-dict "${T}"/ || die
        fi
 }
 
 src_install() {
        insinto /usr/share/migemo
-       doins "${T}/migemo-dict"
+       doins "${T}"/migemo-dict
 }