media-fonts/cantarell: bump to 0.111
authorMart Raudsepp <leio@gentoo.org>
Mon, 21 Jan 2019 20:38:56 +0000 (22:38 +0200)
committerMart Raudsepp <leio@gentoo.org>
Mon, 21 Jan 2019 21:12:57 +0000 (23:12 +0200)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-fonts/cantarell/Manifest
media-fonts/cantarell/cantarell-0.111.ebuild [new file with mode: 0644]

index 461ebaaad05d84df56b7e68301ad6385683778ee..34ba8cfbce4f094403147433d0d5e2bbabdc746a 100644 (file)
@@ -1 +1,2 @@
 DIST cantarell-fonts-0.101.tar.xz 263480 BLAKE2B 79652cf87088a8fe505895cad1f2474e0cb52e4be8a977ae06442a0e8ca6ba6a7f93c811b14e56fd5e61a17c97175b2374d180e435cbac00af8c10b272461802 SHA512 52dbd8358de7e20146e627ab0b1298efb97ee335e45d8e63bab7c3a7d05314d0bb94ac448e34af4c6f7212623185a9e03a30eb24acee4915142e40af0086bbfb
+DIST cantarell-fonts-0.111.tar.xz 326216 BLAKE2B dad338329670674cf3815b2045f8f9a739a9e08913189cec67577982e58df8328e0dc185439bffb6bda0529846b844d0b37a3c9615210f23d47616969f7874b2 SHA512 638298a6381a3ede862d1b100fcfea943bebb5e1c0dc4f1597ab2f841e933b484436b139090a669c770c02483a24f2b92bbd12bce71d7a40eb4c325573e3df9e
diff --git a/media-fonts/cantarell/cantarell-0.111.ebuild b/media-fonts/cantarell/cantarell-0.111.ebuild
new file mode 100644 (file)
index 0000000..4556653
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_ORG_MODULE="${PN}-fonts"
+
+inherit font gnome.org meson
+
+DESCRIPTION="Default fontset for GNOME Shell"
+HOMEPAGE="https://wiki.gnome.org/Projects/CantarellFonts"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="media-libs/fontconfig"
+# appstream-glib provided .loc and .its files required by gettext msgfmt for translation of .metainfo.xml
+DEPEND="
+       dev-libs/appstream-glib
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+# Font eclass settings
+FONT_CONF=("${S}/fontconfig/31-cantarell.conf")
+FONT_S="${S}/prebuilt"
+FONT_SUFFIX="otf"
+
+src_prepare() {
+       # Leave prebuilt font installation to font.eclass
+       sed -e "/subdir('prebuilt')/d" -i meson.build || die
+
+       default
+}
+
+src_configure() {
+       local emesonargs=(
+               -Dfontsdir=${FONTDIR}
+               -Duseprebuilt=true
+               -Dbuildappstream=true
+       )
+       meson_src_configure
+}
+
+src_install() {
+       local DOCS=( NEWS README.md )
+       meson_src_install
+       font_src_install
+}