Add libX11 and xproto deps for bug 153603, thanks to Patrick Lauer for reporting...
authorCharlie Shepherd <masterdriverz@gentoo.org>
Fri, 8 Dec 2006 22:53:43 +0000 (22:53 +0000)
committerCharlie Shepherd <masterdriverz@gentoo.org>
Fri, 8 Dec 2006 22:53:43 +0000 (22:53 +0000)
Package-Manager: portage-2.1.2_rc2-r2

x11-terms/root-tail/ChangeLog
x11-terms/root-tail/root-tail-1.2-r2.ebuild

index 9c9095be65141e59fdb21a8d5be9dd6d306bc020..651fbc9392c458fe1701670cd08d7357a5a22e5d 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for x11-terms/root-tail
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/root-tail/ChangeLog,v 1.37 2006/09/11 20:58:37 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/root-tail/ChangeLog,v 1.38 2006/12/08 22:53:43 masterdriverz Exp $
+
+  08 Dec 2006; Charlie Shepherd <masterdriverz@gentoo.org>
+  -root-tail-1.1.ebuild, -root-tail-1.2-r1.ebuild, root-tail-1.2-r2.ebuild:
+  Add libX11 and xproto deps for bug 153603, thanks to Patrick Lauer for
+  reporting + remove old versions
 
   11 Sep 2006; Thomas Cort <tcort@gentoo.org> root-tail-1.2-r2.ebuild:
   Stable on alpha.
index aae37959f5784a2ea3a559a2ddc3ae797ca75155..bec4af1260870e8c3819759c283c0a059996248d 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/root-tail/root-tail-1.2-r2.ebuild,v 1.10 2006/09/11 20:58:37 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/root-tail/root-tail-1.2-r2.ebuild,v 1.11 2006/12/08 22:53:43 masterdriverz Exp $
 
 inherit eutils flag-o-matic
 
@@ -13,11 +13,12 @@ SLOT="0"
 KEYWORDS="alpha amd64 ppc ppc64 ~sparc x86"
 IUSE="kde debug"
 
-RDEPEND="|| ( x11-libs/libXext virtual/x11 )"
-DEPEND=">=sys-apps/sed-4
-       || ( ( x11-misc/imake
+RDEPEND="|| ( ( x11-libs/libXext x11-libs/libX11 ) virtual/x11 )"
+DEPEND="|| ( ( x11-misc/imake
                        app-text/rman
                        x11-misc/gccmakedep
+                       x11-libs/libX11
+                       x11-proto/xproto
                )
                virtual/x11
        )"
@@ -30,7 +31,7 @@ src_unpack() {
 
 src_compile() {
        xmkmf -a
-       sed -i 's|/usr/X11R6/bin|/usr/bin|' Makefile || die "sed Makefile failed"
+       sed -i 's:/usr/X11R6/bin:/usr/bin:' Makefile || die "sed Makefile failed"
        use debug && append-flags -DDEBUG
        emake || die "emake failed"
 }