sci-visualization/labplot: 2.4.0 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 8 Apr 2017 17:55:40 +0000 (19:55 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 8 Apr 2017 17:59:37 +0000 (19:59 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-visualization/labplot/Manifest
sci-visualization/labplot/labplot-2.4.0.ebuild [new file with mode: 0644]
sci-visualization/labplot/labplot-9999.ebuild

index 689f27edbda88ae69de7e070b5e1e03569b73a0c..a2b212d933cc144c301871d5d3a9ef7b74408561 100644 (file)
@@ -1 +1,2 @@
 DIST labplot-2.3.0-kf5.tar.xz 4531156 SHA256 a5a7d706de5f978430b359ada42f9227a2619f5fa9608d56af16c760b7626f33 SHA512 0f8053bfccbfb6756db14c2d35f69b18bc83395c15cc01cbe61e5877065ad587e1563e7f161dfbac7c75b8b30aa04ee112e0c1962b52544e33ca936bd17b1444 WHIRLPOOL febd50c0a36612a1f93d8190eb9907ede4c29513652cc1a99cfc196c464eb7a7d6bc8692e13a98a9ce31e963a15396385dd9d7b015fe65bd995e2b85e9a09f94
+DIST labplot-2.4.0-kf5.tar.xz 6038072 SHA256 86198247ff0d274c85607cdb07a0c4ef19149e4f4bf6c9d2e6e8249134e26bb2 SHA512 5d29dd7d63d484359e73c8d82d8dbc25a069e1f33829cf75c2a2009ebae2027353ecf578b51806b5f35ae17ec472f5cbfdb4caed2637dc1ecc9229d33033d21b WHIRLPOOL 8d5af85ae52bbe1526d00888c1a18922a0f27c3dbf4ff992736e6672008ca61f54f8df93a1c0185bf4fcdcebe4543e58aa7260eafaf40ba8abf87b39ab84bad4
diff --git a/sci-visualization/labplot/labplot-2.4.0.ebuild b/sci-visualization/labplot/labplot-2.4.0.ebuild
new file mode 100644 (file)
index 0000000..41c5fae
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_BRANCH="frameworks"
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Scientific data analysis and visualisation based on KDE Frameworks"
+HOMEPAGE="https://www.kde.org/applications/education/labplot/"
+[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}-kf5.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="cantor fftw fits hdf5 netcdf"
+
+[[ ${KDE_BUILD_TYPE} != live ]] && S="${WORKDIR}/${P}-kf5"
+
+COMMON_DEPEND="
+       $(add_frameworks_dep karchive)
+       $(add_frameworks_dep kcompletion)
+       $(add_frameworks_dep kconfig)
+       $(add_frameworks_dep kconfigwidgets)
+       $(add_frameworks_dep kcoreaddons)
+       $(add_frameworks_dep kdelibs4support)
+       $(add_frameworks_dep ki18n)
+       $(add_frameworks_dep kiconthemes)
+       $(add_frameworks_dep kio)
+       $(add_frameworks_dep ktextwidgets)
+       $(add_frameworks_dep kwidgetsaddons)
+       $(add_frameworks_dep kxmlgui)
+       $(add_qt_dep qtconcurrent)
+       $(add_qt_dep qtgui)
+       $(add_qt_dep qtprintsupport)
+       $(add_qt_dep qtsvg)
+       $(add_qt_dep qtwidgets)
+       >=sci-libs/gsl-1.15:=
+       cantor? ( $(add_kdeapps_dep cantor) )
+       fftw? ( sci-libs/fftw:3.0= )
+       fits? ( sci-libs/cfitsio:= )
+       hdf5? ( sci-libs/hdf5:= )
+       netcdf? ( sci-libs/netcdf:= )
+"
+DEPEND="${COMMON_DEPEND}
+       sys-devel/gettext
+       x11-misc/shared-mime-info
+"
+RDEPEND="${COMMON_DEPEND}
+       !sci-visualization/labplot:4
+"
+
+src_prepare() {
+       kde5_src_prepare
+
+       if ! use handbook && [[ ${KDE_BUILD_TYPE} != live ]]; then
+               cmake_comment_add_subdirectory doc-translations
+       fi
+
+       punt_bogus_dep KF5 NewStuff
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DENABLE_CANTOR=$(usex cantor)
+               -DENABLE_FFTW=$(usex fftw)
+               -DENABLE_FITS=$(usex fits)
+               -DENABLE_HDF5=$(usex hdf5)
+               -DENABLE_NETCDF=$(usex netcdf)
+       )
+
+       kde5_src_configure
+}
index 463b7dba15eb7bded88f73ba307a19b8e0b2206b..6eebaf152481e8de844152e48ce6f8a6a61bfb8c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -52,11 +52,11 @@ RDEPEND="${COMMON_DEPEND}
 "
 
 src_prepare() {
+       kde5_src_prepare
+
        if ! use handbook && [[ ${KDE_BUILD_TYPE} != live ]]; then
                cmake_comment_add_subdirectory doc-translations
        fi
-
-       kde5_src_prepare
 }
 
 src_configure() {