Cleanup.
authorLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 00:35:00 +0000 (00:35 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 00:35:00 +0000 (00:35 +0000)
Package-Manager: portage-2.1.2_rc4-r8

net-www/mod_auth_pam/ChangeLog
net-www/mod_auth_pam/files/10_mod_auth_pam.conf
net-www/mod_auth_pam/files/10_mod_auth_pam_ap1.conf [new file with mode: 0644]
net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild

index 45d52889ffb583e5080dae249e9de087de59c87a..beec827665dc94f777b7a7c2f4f693a82b50e498 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-www/mod_auth_pam
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/ChangeLog,v 1.15 2006/06/04 19:28:03 vericgar Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/ChangeLog,v 1.16 2007/01/14 00:35:00 chtekk Exp $
+
+  14 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
+  -files/1.1.1-r1/10_mod_auth_pam.conf, files/10_mod_auth_pam.conf,
+  -files/1.1.1-r1-1/10_mod_auth_pam.conf, +files/10_mod_auth_pam_ap1.conf,
+  -files/mod_auth_pam-1.1.1-gentoo.diff, mod_auth_pam-1.1.1-r1.ebuild:
+  Cleanup.
 
   04 Jun 2006; Michael Stewart <vericgar@gentoo.org>
   -mod_auth_pam-1.1.1.ebuild:
index 04fc2bb4ab980eda19072f21b769457efbe4c160..cc5ecd38291f8f44ea546f3b6fb9f92aa078cdde 100644 (file)
@@ -1,14 +1,31 @@
-#<IfDefine AUTH_PAM>
+<IfDefine AUTH_PAM>
   <IfModule !mod_auth_pam.c>
-    LoadModule auth_pam_module         extramodules/mod_auth_pam.so
+    LoadModule auth_pam_module          modules/mod_auth_pam.so
   </IfModule>
-#</IfDefine>
+  <IfModule !mod_auth_sys_group.c>
+    LoadModule auth_sys_group_module    modules/mod_auth_sys_group.so
+  </IfModule>
+</IfDefine>
+
+### EXAMPLE 1: authentificate against a single PAM account
+###
+#      <IfModule mod_auth_pam.c>
+#              AuthPAM_Enabled on
+#
+#              AuthType Basic
+#              AuthName "secure area"
+#              Require user webmaster
+#      </IfModule>
+
+### EXAMPLE 2: authentificate against a a PAM group, so, that each user
+###            beeing in this group may access this "secure area"
+###
+#      <IfModule mod_auth_sys_group.c>
+#              AuthPAM_Enabled on
+#
+#              AuthType Basic
+#              AuthName "secure area"
+#              Require group staff
+#      </IfModule>
 
-#<IfModule mod_auth_pam.c>
-#    AuthPAM_Enabled on
-#    
-#    AuthType Basic
-#    AuthName "secure area"
-#    require group staff
-#    require user webmaster
-#</IfModule>
+# vim:syntax=apache
diff --git a/net-www/mod_auth_pam/files/10_mod_auth_pam_ap1.conf b/net-www/mod_auth_pam/files/10_mod_auth_pam_ap1.conf
new file mode 100644 (file)
index 0000000..674175b
--- /dev/null
@@ -0,0 +1,28 @@
+<IfDefine AUTH_PAM>
+  <IfModule !mod_auth_pam.c>
+    LoadModule pam_auth_module          modules/mod_auth_pam.so
+  </IfModule>
+</IfDefine>
+
+### EXAMPLE 1: authentificate against a single PAM account
+###
+#      <IfModule mod_auth_pam.c>
+#              AuthPAM_Enabled on
+#
+#              AuthType Basic
+#              AuthName "secure area"
+#              Require user webmaster
+#      </IfModule>
+
+### EXAMPLE 2: authentificate against a a PAM group, so, that each user
+###            beeing in this group may access this "secure area"
+###
+#      <IfModule mod_auth_sys_group.c>
+#              AuthPAM_Enabled on
+#
+#              AuthType Basic
+#              AuthName "secure area"
+#              Require group staff
+#      </IfModule>
+
+# vim:syntax=apache
index 8684e1d82a9129cf5c7ba94e2a72d1aa338128db..1e6ef094801cf837e1ca77d94e9ba41c57a20d86 100644 (file)
@@ -1,29 +1,30 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild,v 1.11 2006/04/02 00:36:12 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild,v 1.12 2007/01/14 00:35:00 chtekk Exp $
 
 inherit eutils apache-module portability
 
-RESTRICT="nomirror"
+KEYWORDS="~amd64 ppc ~sparc x86"
 
-DESCRIPTION="PAM authentication module for Apache"
+DESCRIPTION="PAM authentication module for Apache."
 HOMEPAGE="http://pam.sourceforge.net/mod_auth_pam/"
-
 LICENSE="as-is"
-KEYWORDS="~amd64 ppc ~sparc x86"
-DEPEND="sys-libs/pam"
 SLOT="0"
 IUSE="apache2"
+RESTRICT="nomirror"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
 
 APXS1_ARGS="-c ${PN}.c -lpam"
 APXS2_ARGS="-c ${PN}.c -lpam"
 
 APACHE2_EXECFILES=".libs/mod_auth_sys_group.so"
 
-APACHE1_MOD_CONF="${PVR}-1/10_${PN}"
+APACHE1_MOD_CONF="10_${PN}_ap1"
 APACHE1_MOD_DEFINE="AUTH_PAM"
 
-APACHE2_MOD_CONF="${PVR}/10_${PN}"
+APACHE2_MOD_CONF="10_${PN}"
 APACHE2_MOD_DEFINE="AUTH_PAM"
 
 DOCFILES="INSTALL README doc/*"
@@ -31,28 +32,29 @@ DOCFILES="INSTALL README doc/*"
 need_apache
 
 SRC_URI="apache2? ( http://pam.sourceforge.net/mod_auth_pam/dist/${PN}-2.0-${PV}.tar.gz )
-        !apache2? ( http://pam.sourceforge.net/mod_auth_pam/dist/${P}.tar.gz )"
+               !apache2? ( http://pam.sourceforge.net/mod_auth_pam/dist/${P}.tar.gz )"
 
-useq apache2 && S=${WORKDIR}/${PN}
+use apache2 && S="${WORKDIR}/${PN}"
 
 src_unpack() {
-       unpack ${A} || die "unpack failed"
-       cd ${S} || "couldn't cd to \$S"
-       useq apache2 || epatch ${FILESDIR}/${P}-compile-fix.patch || die "patch failed"
-       useq apache2 && sed -i -e 's/servicename = "httpd"/servicename = "apache2"/' ${PN}.c
-       useq apache2 || sed -i -e 's/servicename = "httpd"/servicename = "apache"/' ${PN}.c
+       unpack ${A}
+       cd "${S}"
+
+       use apache2 || epatch "${FILESDIR}/${P}-compile-fix.patch"
+       use apache2 && sed -i -e 's/servicename = "httpd"/servicename = "apache2"/' "${PN}.c"
+       use apache2 || sed -i -e 's/servicename = "httpd"/servicename = "apache"/' "${PN}.c"
 }
 
 src_compile() {
        apache-module_src_compile
-       useq apache2 && ${APXS2} -c mod_auth_sys_group.c
+       use apache2 && ${APXS2} -c mod_auth_sys_group.c
 }
 
 src_install () {
        apache-module_src_install
        insinto /etc/pam.d
-       useq apache2 && newins ${FILESDIR}/apache2.pam apache2
-       useq apache2 || newins ${FILESDIR}/apache2.pam apache
+       use apache2 && newins "${FILESDIR}/apache2.pam" apache2
+       use apache2 || newins "${FILESDIR}/apache2.pam" apache
 }
 
 pkg_postinst() {
@@ -62,9 +64,9 @@ pkg_postinst() {
        einfo
        einfo "If the system is configured with the shadow authentication method"
        einfo "the following commands must be executed by root to make /etc/shadow"
-       einfo "accessible by the apache server:"
+       einfo "accessible by the Apache webserver:"
        einfo
-       if [ -z "${gid}" ]; then
+       if [[ -z "${gid}" ]] ; then
                einfo "    # groupadd shadow"
                einfo "    # gpasswd -a apache shadow"
        fi