Version bump. Removed obsolete ebuilds.
authorAndrej Kacian <ticho@gentoo.org>
Fri, 5 Jan 2007 17:40:15 +0000 (17:40 +0000)
committerAndrej Kacian <ticho@gentoo.org>
Fri, 5 Jan 2007 17:40:15 +0000 (17:40 +0000)
Package-Manager: portage-2.1.2_rc4-r1

net-mail/getmail/ChangeLog
net-mail/getmail/files/digest-getmail-4.6.7 [new file with mode: 0644]
net-mail/getmail/getmail-4.6.7.ebuild [new file with mode: 0644]

index 0b951462cba13a4a7328dd7676700df9e2e0f601..5158c91c744e33b89c38bbd36c503c0fcba75792 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-mail/getmail
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.135 2006/12/12 16:43:55 ticho Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.136 2007/01/05 17:40:15 ticho Exp $
+
+*getmail-4.6.7 (05 Jan 2007)
+
+  05 Jan 2007; Andrej Kacian <ticho@gentoo.org> -getmail-4.4.4.ebuild,
+  -getmail-4.5.4.ebuild, -getmail-4.6.0.ebuild, -getmail-4.6.1.ebuild,
+  +getmail-4.6.7.ebuild:
+  Version bump. Removed obsolete ebuilds.
 
 *getmail-4.6.6 (12 Dec 2006)
 
diff --git a/net-mail/getmail/files/digest-getmail-4.6.7 b/net-mail/getmail/files/digest-getmail-4.6.7
new file mode 100644 (file)
index 0000000..89da7ee
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 8dcda9b02eb91772a844e8935ea26429 getmail-4.6.7.tar.gz 143879
+RMD160 8a6b7db919457173237ed44bfc329778ea4e23fe getmail-4.6.7.tar.gz 143879
+SHA256 e904e142c00aeaa9edb6c699e69049af64099e63833a29ceadfe9a6985bf73e8 getmail-4.6.7.tar.gz 143879
diff --git a/net-mail/getmail/getmail-4.6.7.ebuild b/net-mail/getmail/getmail-4.6.7.ebuild
new file mode 100644 (file)
index 0000000..3e5d3da
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.6.7.ebuild,v 1.1 2007/01/05 17:40:15 ticho Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_compile() {
+       distutils_src_compile
+}
+
+src_install() {
+       distutils_src_install
+
+       if has_version "=net-mail/getmail-3*" ; then
+               mv ${D}/usr/bin/getmail ${D}/usr/bin/getmail4
+               mv ${D}/usr/bin/getmail_maildir ${D}/usr/bin/getmail_maildir4
+               mv ${D}/usr/bin/getmail_mbox ${D}/usr/bin/getmail_mbox4
+       fi
+
+       # handle docs the gentoo way
+       if [ ${P} != ${PF} ]; then
+               mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+       fi
+
+       dodir /usr/share/doc/${PF}/html
+       mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/*.css ${D}/usr/share/doc/${PF}/html
+       gzip --silent ${D}/usr/share/doc/${PF}/*
+}
+
+pkg_postinst() {
+       python_version
+       python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+       if has_version "=net-mail/getmail-3*" ; then
+               echo
+               ewarn "An already installed instance of getmail v3 was detected. In order to"
+               ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+               ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+               echo
+       fi
+}
+
+pkg_postrm() {
+       python_version
+       python_mod_cleanup
+}