net-misc/grive: version bump
authorChristoph Junghans <junghans@gentoo.org>
Mon, 25 May 2020 16:02:33 +0000 (10:02 -0600)
committerChristoph Junghans <junghans@gentoo.org>
Mon, 25 May 2020 16:03:22 +0000 (10:03 -0600)
Bug: https://bugs.gentoo.org/725184
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Christoph Junghans <junghans@gentoo.org>
net-misc/grive/Manifest
net-misc/grive/grive-0.5.1.ebuild [new file with mode: 0644]

index e3107285d5ce9edd4aa4611db8d5b8c38e7d381c..aa8aae7a56bb3e563942770fd18a5ddc1fbd3ecd 100644 (file)
@@ -1 +1,2 @@
+DIST grive-0.5.1.tar.gz 169929 BLAKE2B a8f8fc9f3bcf019b7b713178f6a39ca6c62f6531054329d4ff8ac6fbfdfa5579f9e51aa8f9c493b90005194c3ab77934575e541c0986404a32e807c5c87c4cfd SHA512 609837fc93ad78d143dcb4d1f558743d413c887fec2e9aaac81edd58549b812db859aab5ce7f664f06564779cff4bae32d43529e47fcc36640f1a9b52c5b5888
 DIST grive-0.5.1_pre20171005.tar.gz 164450 BLAKE2B e8fde261ec419c1284575032ce326de4953ecf7b4824a70aec07b41f6013b4d26532ba0eae3897c910bd5bb51949dcc13fcb699013557f24c38c75fb251e868c SHA512 d1f2b3bb5206aef3afeebd48f198a287f97a016f5da00f954fbdcf366ea7178c0e2c6e48250cdb0869bc850380ed09790b5bbdc1ecf3cdd7b484fcf9b85c793c
diff --git a/net-misc/grive/grive-0.5.1.ebuild b/net-misc/grive/grive-0.5.1.ebuild
new file mode 100644 (file)
index 0000000..04bfdf1
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ ${PV} = *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/vitalif/${PN}2.git"
+else
+       inherit vcs-snapshot
+       SRC_URI="https://github.com/vitalif/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An open source Linux client for Google Drive"
+HOMEPAGE="https://github.com/vitalif/grive2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=
+       dev-libs/expat
+       >=dev-libs/json-c-0.11-r1:=
+       dev-libs/libgcrypt:0=
+       dev-libs/yajl
+       || ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] )
+       sys-libs/binutils-libs:0=
+       sys-libs/glibc
+"
+DEPEND="${RDEPEND}"