dev-libs/libbytesize: Removed old
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 21 May 2020 10:49:24 +0000 (12:49 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 21 May 2020 10:49:35 +0000 (12:49 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
dev-libs/libbytesize/Manifest
dev-libs/libbytesize/libbytesize-1.4.ebuild [deleted file]
dev-libs/libbytesize/libbytesize-2.1.ebuild [deleted file]

index 4b660c558f692931581757cd93782734e02e69c5..89aa9afc7013045e23f1df2788824b7b2ef43019 100644 (file)
@@ -1,4 +1,2 @@
-DIST libbytesize-1.4.tar.gz 80943 BLAKE2B d4c6c34d81be01bf7db2c37b0660886d99eff3c0a87024f5fbc12cc3606dc01e772b81dfbcacbf76c62213120253a9e7bda90adbc749b6d4c3e31e1ed3ae7702 SHA512 5dd13cf52a1674be776220ee1863f42261a47dc53af1ce4a31460d6d02ce87e19c5a52260f700928af98f1d9d7a96de7c11d8f384907b3187ef2effc10cbb593
-DIST libbytesize-2.1.tar.gz 440209 BLAKE2B 7c689f269eae7b408b7f85fb9c877c9eb519d2a2eb143ef0ddb1657fbb4d79fab7cdaa56b35b4bbbb964e47361e37d7c70a0a135bacb8f817bd6cf8d2e22b68e SHA512 6b93d877e921820c19ed6874a36d9f8b6958112f6230f24980e8e6e30570b39ce74594f0ef126f70dc81b5434899c1f0f3ad0925f3ff7b6a596a9329c8f106c8
 DIST libbytesize-2.2.tar.gz 443040 BLAKE2B 04035f99f1da4d2d426106e1f292d71089dae89923d41425fa815a72e375639a7d8b6fc5552a3f08462597ce9c19797c7fce5b79fdad504b9062168093a70a4f SHA512 4538ac3499a24023c21fe07f527e400f99509921e377248970ac2da0eaf1655ddb261f432eed46a59ef69a1275ba7d1e5b0cc488d64eeea936b6cfa54c552ac1
 DIST libbytesize-2.3.tar.gz 438198 BLAKE2B 583450b66781bbb16298507292ffe60012ccc296f0822784ead13bcf1ce3f9a9cf7c2341d5f64d3356fb78aefb3e6b0770bce64ebf85aa92d168277d35f9629c SHA512 23720b90f4dbf7880a640ec04e910c4c1f34637dd3621900772187cb2e1d04ec34d4900ce3c9b4083ac462b411d5a409a644f62ed76b2c57ef1f11432c58be8a
diff --git a/dev-libs/libbytesize/libbytesize-1.4.ebuild b/dev-libs/libbytesize/libbytesize-1.4.ebuild
deleted file mode 100644 (file)
index 617d352..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit autotools python-r1
-
-DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
-HOMEPAGE="https://github.com/storaged-project/libbytesize"
-SRC_URI="https://github.com/storaged-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="doc test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
-       ${PYTHON_DEPS}
-       dev-libs/gmp:0=
-       dev-libs/mpfr:=
-       >=dev-libs/libpcre-8.32
-"
-
-DEPEND="
-       ${RDEPEND}
-       sys-devel/gettext
-       doc? ( dev-util/gtk-doc )
-       test? (
-               dev-python/pocketlint
-               dev-python/polib
-       )
-"
-
-RESTRICT="test"
-
-pkg_setup() {
-       python_setup
-}
-
-src_prepare() {
-       default
-       eautoreconf
-}
-
-src_configure() {
-       local myeconfargs=(
-               --without-python3 #634840
-               $(use_with doc gtk-doc)
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_install() {
-       emake install DESTDIR="${D}"
-
-       python_install() {
-               emake -C src/python install DESTDIR="${D}"
-               python_optimize
-       }
-       python_foreach_impl python_install
-
-       find "${ED}" -name "*.la*" -delete || die
-}
diff --git a/dev-libs/libbytesize/libbytesize-2.1.ebuild b/dev-libs/libbytesize/libbytesize-2.1.ebuild
deleted file mode 100644 (file)
index 0d91bc5..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit python-r1
-
-DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
-HOMEPAGE="https://github.com/storaged-project/libbytesize"
-SRC_URI="https://github.com/storaged-project/libbytesize/releases/download/${PV}/${P}.tar.gz"
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc python test tools"
-
-REQUIRED_USE="
-       python? ( ${PYTHON_REQUIRED_USE} )
-       tools? ( python )
-"
-
-RDEPEND="
-       dev-libs/gmp:0=
-       dev-libs/mpfr:=
-       dev-libs/libpcre2
-       python? ( ${PYTHON_DEPS} )
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
-       sys-devel/gettext
-       doc? ( dev-util/gtk-doc )
-       test? (
-               dev-python/pocketlint[${PYTHON_USEDEP}]
-               dev-python/polib[${PYTHON_USEDEP}]
-       )
-"
-
-DOCS=( README.md )
-
-RESTRICT="test"
-
-python_do() {
-       if use python; then
-               python_foreach_impl run_in_build_dir "$@"
-       else
-               "$@"
-       fi
-}
-
-src_configure() {
-       local myeconfargs=(
-               $(use_with doc gtk-doc)
-               $(use_with python python3)
-               $(use_with tools)
-       )
-       local ECONF_SOURCE="${S}"
-       python_do econf "${myeconfargs[@]}"
-}
-
-src_compile() {
-       python_do emake
-}
-
-src_test() {
-       python_do emake check
-}
-
-install_helper() {
-       emake DESTDIR="${D}" install
-       use python && python_optimize
-}
-
-src_install() {
-       python_do install_helper
-       einstalldocs
-       find "${ED}" -name "*.la" -type f -delete || die
-}