app-emulation/spice-vdagent: glorious version bump
authorMatthias Maier <tamiko@gentoo.org>
Sat, 18 Apr 2020 19:04:58 +0000 (14:04 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sat, 18 Apr 2020 19:04:58 +0000 (14:04 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/spice-vdagent/Manifest
app-emulation/spice-vdagent/spice-vdagent-0.20.0.ebuild [new file with mode: 0644]

index 648624b8dad0f6844ad74bde29ce2abf32bed060..d62998b6b3ac5873203ae0e75c69ce111ce0ceef 100644 (file)
@@ -1 +1,2 @@
 DIST spice-vdagent-0.19.0.tar.bz2 151356 BLAKE2B b7a99a7205d955b27edfe483746e3f267a6e0b7885c4b8146ba42d99b581cf4e1748b503a37a3d6b66623ef2515b42756f2e6a5a4775d56def7aa396bd0dfb4f SHA512 f5056dfe66df3ee8205549be22bbc8c17d2196c8448eda97f01659ff30c34d9929f330767d7fafec557dc5f7fb9b65eaf85973193b38df774042de9b72d6e60d
+DIST spice-vdagent-0.20.0.tar.bz2 152510 BLAKE2B b00caadab385f4208bd18b78a006831953f99387e55fd86226efffdf537426627f02bb46708173b700eecd21f598a0db94f454c5252b0f4bfb93c30b39d69d16 SHA512 a6288e056645c071834f9ce5800669cb64e0f86a5efeb8eec61ac1e11f1fd56f7da8ea19b28a94c88741d794a0290fac9bcf74d45bcef271c2c5abfb2573a8e1
diff --git a/app-emulation/spice-vdagent/spice-vdagent-0.20.0.ebuild b/app-emulation/spice-vdagent/spice-vdagent-0.20.0.ebuild
new file mode 100644 (file)
index 0000000..2cac381
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+DESCRIPTION="SPICE VD Linux Guest Agent"
+HOMEPAGE="https://www.spice-space.org/"
+SRC_URI="https://www.spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="consolekit gtk selinux systemd"
+
+CDEPEND="
+       dev-libs/glib:2
+       >=app-emulation/spice-protocol-0.14.0
+       media-libs/alsa-lib
+       >=x11-libs/libpciaccess-0.10
+       x11-libs/libdrm
+       x11-libs/libXfixes
+       x11-libs/libXrandr
+       x11-libs/libX11
+       x11-libs/libXinerama
+       consolekit? ( sys-auth/consolekit sys-apps/dbus )
+       gtk? ( x11-libs/gtk+:3 )
+       systemd? ( sys-apps/systemd )"
+DEPEND="${CDEPEND}
+       virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+       selinux? ( sec-policy/selinux-vdagent )"
+
+CONFIG_CHECK="~INPUT_UINPUT ~VIRTIO_CONSOLE"
+ERROR_INPUT_UINPUT="User level input support (INPUT_UINPUT) is required"
+ERROR_VIRTIO_CONSOLE="VirtIO console/serial device support (VIRTIO_CONSOLE) is required"
+
+src_configure() {
+       local opt=()
+       if use consolekit; then
+               opt+=( --with-session-info=console-kit )
+       elif use systemd; then
+               opt+=( --with-session-info=systemd )
+       else
+               opt+=( --with-session-info=none )
+       fi
+
+       econf \
+               --with-init-script=systemd \
+               --localstatedir="${EPREFIX}"/var \
+               $(use_with gtk) \
+               "${opt[@]}"
+}
+
+src_install() {
+       default
+
+       cd "${ED}" && rmdir -p var/run/spice-vdagentd || die
+
+       keepdir /var/log/spice-vdagentd
+
+       newinitd "${FILESDIR}/${PN}.initd-4" "${PN}"
+       newconfd "${FILESDIR}/${PN}.confd-2" "${PN}"
+}