dev-python/boto3-9999: sync with 1.12.48
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 29 Apr 2020 19:10:54 +0000 (12:10 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 29 Apr 2020 19:12:00 +0000 (12:12 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/boto3/boto3-9999.ebuild

index b19ce9f817ab667fce6e4d1d82661bf8b58454a5..d996a7288df90959f086e9cc91549f2efd6ed2d6 100644 (file)
@@ -1,17 +1,16 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit distutils-r1 vcs-snapshot
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
 
 DESCRIPTION="The AWS SDK for Python"
 HOMEPAGE="https://github.com/boto/boto3"
 LICENSE="Apache-2.0"
 SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
+IUSE="test"
 
 if [[ "${PV}" == "9999" ]]; then
        EGIT_REPO_URI="https://github.com/boto/boto3"
@@ -22,33 +21,35 @@ else
 fi
 
 RDEPEND="
-       >=dev-python/botocore-1.12.4[${PYTHON_USEDEP}]
-       dev-python/jmespath[${PYTHON_USEDEP}]
-       dev-python/s3transfer[${PYTHON_USEDEP}]
+       >=dev-python/botocore-1.15.48[${PYTHON_USEDEP}]
+       >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+       >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
 "
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
-               dev-python/sphinx[${PYTHON_USEDEP}]
-       )
-       test? (
-               ${RDEPEND}
+BDEPEND="
+       test? ( ${RDEPEND}
                dev-python/mock[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}]
        )
 "
 
-python_compile_all() {
-       use doc && emake -C docs html
+RESTRICT="!test? ( test )"
+
+distutils_enable_sphinx docs \
+       'dev-python/guzzle_sphinx_theme'
+
+python_prepare_all() {
+       # don't lock versions to narrow ranges
+       sed -e '/botocore/ d' \
+               -e '/jmespath/ d' \
+               -e '/s3transfer/ d' \
+               -i setup.py || die
+
+       # prevent an infinite loop
+       rm tests/functional/docs/test_smoke.py || die
+
+       distutils-r1_python_prepare_all
 }
 
 python_test() {
        nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
 }
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-
-       distutils-r1_python_install_all
-}