net-dns/dnswalk: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 18 Jan 2020 17:35:46 +0000 (18:35 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 18 Jan 2020 17:35:46 +0000 (18:35 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
net-dns/dnswalk/dnswalk-2.0.2.ebuild
net-dns/dnswalk/files/dnswalk-2.0.2-portable-shebang.patch [new file with mode: 0644]

index 561f12577ffad738473c6a0888e6565d93568479..8114b78757d5191fc881908a068a4a2fca90a7eb 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 DESCRIPTION="dnswalk is a DNS database debugger"
 HOMEPAGE="https://sourceforge.net/projects/dnswalk/"
@@ -13,16 +13,14 @@ KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
 
 RDEPEND=">=dev-perl/Net-DNS-0.12"
 
-S=${WORKDIR}
+S="${WORKDIR}"
 
-src_prepare() {
-       sed -i 's:#!/usr/contrib/bin/perl:#!'"${EPREFIX}"'/usr/bin/perl:' dnswalk
-}
+PATCHES=( "${FILESDIR}"/${PN}-2.0.2-portable-shebang.patch )
 
-src_install () {
+src_install() {
        dobin dnswalk
 
-       dodoc CHANGES README TODO \
-               do-dnswalk makereports sendreports rfc1912.txt dnswalk.errors
+       einstalldocs
+       dodoc do-dnswalk makereports sendreports rfc1912.txt dnswalk.errors
        doman dnswalk.1
 }
diff --git a/net-dns/dnswalk/files/dnswalk-2.0.2-portable-shebang.patch b/net-dns/dnswalk/files/dnswalk-2.0.2-portable-shebang.patch
new file mode 100644 (file)
index 0000000..f194ea7
--- /dev/null
@@ -0,0 +1,8 @@
+--- a/dnswalk
++++ b/dnswalk
+@@ -1,4 +1,4 @@
+-#!/usr/contrib/bin/perl
++#!/usr/bin/env perl
+ #
+ # dnswalk    Walk through a DNS tree, pulling out zone data and
+ # dumping it in a directory tree