dev-python/MechanicalSoup: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 21:21:42 +0000 (22:21 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 21:21:42 +0000 (22:21 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/MechanicalSoup/Manifest
dev-python/MechanicalSoup/MechanicalSoup-0.10.0.ebuild [deleted file]

index c28b8c48d2b961530f32d1903816625568c1d8cc..0e84d9339704433c29ac431d7ddfa9a7020844e3 100644 (file)
@@ -1,2 +1 @@
-DIST MechanicalSoup-0.10.0.tar.gz 40111 BLAKE2B cbb09253666850d3ce433f60ed6405585588e6dc7198c58de1cab8ecfad1e1c814433787aefe33dbb490edab5367ffca285d14cf8fbcb2c16e309b957a3a311b SHA512 5fa493abac39c5084dacb67b9dfaa2f8f5af773d3e3aaff48e6240596e863ada30a2fd1e345188c3249fd6e570977aa45b9fd553fe5a549f8430f170613bb866
 DIST MechanicalSoup-0.12.0.tar.gz 44505 BLAKE2B 7c303f7ae4dea12157d5c845a4dcdc6923e76d3565debd88d2f43e2cfc29a503feb6accb969839a39b1c4071b029f53908a12902a5c4f175f0383da227224c55 SHA512 6cce80ea5a90e7f19f2b13749f6ee48222d973af66cb350ac867a554580b0d619defe5a93741e6ec8aa808c585a8c01703158c7484521ac069977388de8bb7e3
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-0.10.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-0.10.0.ebuild
deleted file mode 100644 (file)
index 58f9c75..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A python library for automating interaction with websites"
-HOMEPAGE="https://pypi.org/project/MechanicalSoup/"
-# https://github.com/MechanicalSoup/MechanicalSoup/pull/217
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-# https://github.com/MechanicalSoup/MechanicalSoup/issues/215
-RESTRICT="test"
-
-RDEPEND="
-       >=dev-python/beautifulsoup-4.0[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.0[${PYTHON_USEDEP}]
-       >=dev-python/six-1.4[${PYTHON_USEDEP}]
-       dev-python/lxml[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               ${RDEPEND}
-               >=dev-python/requests-mock-1.3.0[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-httpbin[${PYTHON_USEDEP}]
-               dev-python/pytest-mock[${PYTHON_USEDEP}]
-       )
-"
-
-python_prepare_all() {
-       sed -i "s/'pytest-runner'//" setup.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs docs/_build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       # Override pytest options to skip coverage and flake8
-       py.test --override-ini="addopts=" \
-               || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       if use examples; then
-               docompress -x "/usr/share/doc/${PF}/examples"
-               dodoc -r examples
-       fi
-       distutils-r1_python_install_all
-}