dev-python/psutil: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 19 Feb 2020 06:53:43 +0000 (07:53 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 19 Feb 2020 06:53:43 +0000 (07:53 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/psutil/Manifest
dev-python/psutil/files/psutil-5.6.5-tests.patch [deleted file]
dev-python/psutil/psutil-5.4.8.ebuild [deleted file]
dev-python/psutil/psutil-5.5.0.ebuild [deleted file]
dev-python/psutil/psutil-5.6.0.ebuild [deleted file]
dev-python/psutil/psutil-5.6.5.ebuild [deleted file]

index bbf5dadec5ec4a1a33fe71683d9c71c7f8223455..50a5c6357b2347a3f7886c570487957614374c22 100644 (file)
@@ -1,6 +1,2 @@
-DIST psutil-5.4.8.tar.gz 422742 BLAKE2B 13c4b9b412704728c4b192032a6be78756b03a37cd6f425a81a83d0aca4ce155ebf24a1f62b75e66433f21e8bd3f2fa3c7bbb5ec2686c6dc951b89e97ebfa688 SHA512 5691e7e7ecd827aff2755a85c4c1be3a23beec3a1dbff079547991dcfffa8e075cff7fb6983e1f6fa287e2216e3b1466618730afaf114a0ee209d7b70d7b0c6a
-DIST psutil-5.5.0.tar.gz 425058 BLAKE2B 0a13149b060d1a99faa600470fdbd592ee520b247f916313bef428feaa652bc4e9152f09ceeea5378769d4cdcd9876ccdc96dc4378d74136bcbcadf4a9266b90 SHA512 e614d41162087e236779738b50ec9e83403082f20492e152605fe80da23a11a4bd667db82a234f00815f68139d53b19368c2118ab27d52144341c2250091c570
-DIST psutil-5.6.0.tar.gz 426596 BLAKE2B 803cb09262575a7193ecc9cf9bfbbf721e10ef4adc25672f6747111306d1803c1422c9894636421653eaae11c241100f58837c80173ab473bb9dc39da2580aed SHA512 01daf80698954a53a9e987afad6c7aefad502c76b5f34601728c3864c924ca52099f139242e508fd4c72378cbe436c9870eca7a33c112fb8dead0be501aaf2aa
-DIST psutil-5.6.5.tar.gz 447489 BLAKE2B 9301d1580bded927b4b117facf82a3c6be9b43cb648f0f52b841dc2c59cbcc58b5a5c3e0ea7cee30a546e1ea1c00fc0e03b3b49fa69209bbfd3c873e18510859 SHA512 037b1501b686b7101be4180c8698b09d20d4260962a88f0c437ff558d91c405f56eae186c9d55c1893c612c4534093ab26e6943f0ed56db69e343c5c0317be1b
 DIST psutil-5.6.7.tar.gz 448321 BLAKE2B 4e47fb7def5a0eed162686d4e90dd122bd380eca50c3294cd89ed154e27f71972dbc2b3b481456d5022107a1adad2a637e8f233002d429463232c38a04a957c7 SHA512 74eb488b91764941e38214f07bca00e3c837167ad543bfd9ae3b83d665e2be1bb5341eca4aff9282ad50d321568a679e1ffa2ee72ad7b4965cda92b7c80b2503
 DIST psutil-5.7.0.tar.gz 449628 BLAKE2B 3bd07a0a2f95a539910fa1cef92e72d168c3ee7a495c0defd3fad307d96448d81182b7ccc5e4388d6726495a18df26b076e27b3cbf57096a5c3c8326c00f2dea SHA512 8cee64ab396dae79866e961aeabdb9a4174e1339bcd5c0a35f23fee97ca2a61c0cb08f7152d7e0db90c387400c5c6fb3da2dd2124ce9bf97dfffe6f3b4967981
diff --git a/dev-python/psutil/files/psutil-5.6.5-tests.patch b/dev-python/psutil/files/psutil-5.6.5-tests.patch
deleted file mode 100644 (file)
index ab06ffd..0000000
+++ /dev/null
@@ -1,90 +0,0 @@
-diff --git a/psutil/_pslinux.py b/psutil/_pslinux.py
-index 80fbf8bf..13c195b8 100644
---- a/psutil/_pslinux.py
-+++ b/psutil/_pslinux.py
-@@ -1108,7 +1108,7 @@ def disk_io_counters(perdisk=False):
-                     fields = f.read().strip().split()
-                 name = os.path.basename(root)
-                 (reads, reads_merged, rbytes, rtime, writes, writes_merged,
--                    wbytes, wtime, _, busy_time, _) = map(int, fields)
-+                 wbytes, wtime, _, busy_time, _) = map(int, fields[:11])
-                 yield (name, reads, writes, rbytes, wbytes, rtime,
-                        wtime, reads_merged, writes_merged, busy_time)
-diff --git a/psutil/tests/test_contracts.py b/psutil/tests/test_contracts.py
-index cb4a2b96..1ff7f6ca 100755
---- a/psutil/tests/test_contracts.py
-+++ b/psutil/tests/test_contracts.py
-@@ -174,6 +174,7 @@ class TestAvailability(unittest.TestCase):
- class TestDeprecations(unittest.TestCase):
-+    @unittest.skip("broken with newer deps")
-     def test_memory_info_ex(self):
-         with warnings.catch_warnings(record=True) as ws:
-             psutil.Process().memory_info_ex()
-diff --git a/psutil/tests/test_linux.py b/psutil/tests/test_linux.py
-index ccde735d..db7183af 100755
---- a/psutil/tests/test_linux.py
-+++ b/psutil/tests/test_linux.py
-@@ -380,9 +380,10 @@ class TestSystemVirtualMemory(unittest.TestCase):
-                 ret = psutil.virtual_memory()
-             assert m.called
-             self.assertEqual(ret.available, 2057400 * 1024 + 4818144 * 1024)
--            w = ws[0]
--            self.assertIn(
--                "inactive memory stats couldn't be determined", str(w.message))
-+            # i have no idea what they are trying to do here
-+            #w = ws[0]
-+            #self.assertIn(
-+            #    "inactive memory stats couldn't be determined", str(w.message))
-     def test_avail_old_missing_zoneinfo(self):
-         # Remove /proc/zoneinfo file. Make sure fallback is used
-@@ -410,10 +411,12 @@ class TestSystemVirtualMemory(unittest.TestCase):
-                     ret = psutil.virtual_memory()
-                     self.assertEqual(
-                         ret.available, 2057400 * 1024 + 4818144 * 1024)
--                    w = ws[0]
--                    self.assertIn(
--                        "inactive memory stats couldn't be determined",
--                        str(w.message))
-+
-+                    # i have no idea what they are trying to do here
-+                    #w = ws[0]
-+                    #self.assertIn(
-+                    #    "inactive memory stats couldn't be determined",
-+                    #    str(w.message))
-     def test_virtual_memory_mocked(self):
-         # Emulate /proc/meminfo because neither vmstat nor free return slab.
-@@ -878,7 +881,7 @@ class TestLoadAvg(unittest.TestCase):
- # =====================================================================
--@unittest.skipIf(not LINUX, "LINUX only")
-+@unittest.skipIf(not LINUX or True, "Not working with latest ipaddress")
- class TestSystemNetIfAddrs(unittest.TestCase):
-     def test_ips(self):
-diff --git a/psutil/tests/test_process.py b/psutil/tests/test_process.py
-index 24a29b5a..9d9d36d2 100755
---- a/psutil/tests/test_process.py
-+++ b/psutil/tests/test_process.py
-@@ -950,7 +950,7 @@ class TestProcess(unittest.TestCase):
-         for combo in combos:
-             p.cpu_affinity(combo)
--            self.assertEqual(p.cpu_affinity(), combo)
-+            self.assertEqual(set(p.cpu_affinity()), set(combo))
-     # TODO: #595
-     @unittest.skipIf(BSD, "broken on BSD")
-@@ -1486,6 +1486,7 @@ class TestProcess(unittest.TestCase):
-         d2 = clean_dict(os.environ.copy())
-         self.assertEqual(d1, d2)
-+    @unittest.skipIf(TRAVIS, "broken under sandbox, using TRAVIS for Gentoo")
-     @unittest.skipIf(not HAS_ENVIRON, "not supported")
-     @unittest.skipIf(not POSIX, "POSIX only")
-     def test_weird_environ(self):
diff --git a/dev-python/psutil/psutil-5.4.8.ebuild b/dev-python/psutil/psutil-5.4.8.ebuild
deleted file mode 100644 (file)
index 02ce4a8..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Retrieve information on running processes and system utilization"
-HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.org/project/psutil/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/ipaddress[${PYTHON_USEDEP}]
-       )
-"
-
-# Many tests fail, even on a regular tox run on a upstream clone
-RESTRICT="test"
-
-python_test() {
-       ${PYTHON} psutil/tests/__main__.py || die
-}
diff --git a/dev-python/psutil/psutil-5.5.0.ebuild b/dev-python/psutil/psutil-5.5.0.ebuild
deleted file mode 100644 (file)
index 98afea2..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Retrieve information on running processes and system utilization"
-HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.org/project/psutil/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/ipaddress[${PYTHON_USEDEP}]
-       )
-"
-
-# Many tests fail, even on a regular tox run on a upstream clone
-RESTRICT="test"
-
-python_test() {
-       ${PYTHON} psutil/tests/__main__.py || die
-}
diff --git a/dev-python/psutil/psutil-5.6.0.ebuild b/dev-python/psutil/psutil-5.6.0.ebuild
deleted file mode 100644 (file)
index 205a8af..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Retrieve information on running processes and system utilization"
-HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.org/project/psutil/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/ipaddress[${PYTHON_USEDEP}]
-       )
-"
-
-# Many tests fail, even on a regular tox run on a upstream clone
-RESTRICT="test"
-
-python_test() {
-       ${PYTHON} psutil/tests/__main__.py || die
-}
diff --git a/dev-python/psutil/psutil-5.6.5.ebuild b/dev-python/psutil/psutil-5.6.5.ebuild
deleted file mode 100644 (file)
index c33d3e6..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Retrieve information on running processes and system utilization"
-HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.org/project/psutil/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/ipaddress[${PYTHON_USEDEP}]
-       )
-"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
-       "${FILESDIR}/psutil-5.6.5-tests.patch"
-)
-
-python_test() {
-       if [[ ${EPYTHON} == pypy* ]]; then
-               ewarn "Not running tests on ${EPYTHON} since they are broken"
-               return 0
-       fi
-
-       # since we are running in an environment a bit similar to CI,
-       # let's skip the tests that are disable for CI
-       TRAVIS=1 APPVEYOR=1 PYTHONPATH="${BUILD_DIR}/lib" ${PYTHON} psutil/tests/__main__.py || \
-               die "tests failed with ${EPYTHON}"
-}