dev-python/pygame: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:52:15 +0000 (09:52 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:52:15 +0000 (09:52 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pygame/Manifest
dev-python/pygame/files/pygame-1.9.2_pre20120101-import-bdist.patch [deleted file]
dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild [deleted file]

index ff4413caf99b56ad49539933417aaa0d390764ab..4740c1c3f0c95f3f09f0971095ab64ce889d8a8c 100644 (file)
@@ -1,3 +1,2 @@
-DIST pygame-1.9.2_pre20120101.tar.xz 2263028 BLAKE2B 401b7cdc32cfc6b960e8a686236d0a310d840b4a41211b602f6fe137f80f3bb358daa5e25758c4e152ab41e50c3864c183a0b6f36176e3dec12db80449e126e1 SHA512 1e82cf720da28d4e4213f6b7a029ab4c9dd592c3155f3d11da8272a7d81d28c54f93402383fa5fa4a4e8863dfc039062838d0317cfedde30a4455e52ce680576
 DIST pygame-1.9.3.tar.gz 2974541 BLAKE2B 38ba1f85d845cf33202819705ad564168fb3bc7041731d50d8c3f6bf1c55bebf41202f8ae9e4c4ba52cabe7335a9df13d7724104015b49842dc7f7aa7b0bfd19 SHA512 8920c598a97b4ff8602391517f070b67263bacb6330e13ea5d7d5432ee592a7c984fe986837b90a032da3d4e717f9df0cc99f0fb39f1cbde1b4f6a4c132feffe
 DIST pygame-1.9.6.tar.gz 3223131 BLAKE2B a4d04c933fcad244d32bd512ef8717e60ec923f361e9e0296b5c7d57c5949d3434a040d028249c5b8f3c865ac3dcdbb32e6f0b223186678595a8625213ba2a17 SHA512 d923c554203a7c35e37921658cb4c5bf50215ab0ff4d2b869a1ee6b2e2ca31d66ec4bbde4287f5a777838ffe932cd15b993cb0224b86e43d684de61c35acbcd0
diff --git a/dev-python/pygame/files/pygame-1.9.2_pre20120101-import-bdist.patch b/dev-python/pygame/files/pygame-1.9.2_pre20120101-import-bdist.patch
deleted file mode 100644 (file)
index f587401..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-From f5ee3952769d698d7d03ae61a9c70f2ec4d85874 Mon Sep 17 00:00:00 2001
-From: "Markus (root)" <mo@wurzel.org>
-Date: Sun, 19 Oct 2014 16:56:41 +0200
-Subject: [PATCH] This fails with a TypeError, but offers no functionality.
-
----
- pygame-1.9.2_pre20120101-python3_3/setup.py | 26 +++++++++++++-------------
- 1 file changed, 13 insertions(+), 13 deletions(-)
-
-diff --git a/pygame-1.9.2_pre20120101-python3_3/setup.py b/pygame-1.9.2_pre20120101-python3_3/setup.py
-index ecee5d1..b913f18 100644
---- a/pygame-1.9.2_pre20120101-python3_3/setup.py
-+++ b/pygame-1.9.2_pre20120101-python3_3/setup.py
-@@ -99,19 +99,19 @@ if "-setuptools" in sys.argv:
-     sys.argv.remove ("-setuptools")
--# NOTE: the bdist_mpkg_support is for darwin.
--try:
--    import bdist_mpkg_support
--    from setuptools import setup, Extension
--except ImportError:
--    pass
--else:
--    EXTRAS.update({
--        'options': bdist_mpkg_support.options,
--        'setup_requires': ['bdist_mpkg>=0.4.2'],
--        #'install_requires': ['pyobjc'],
--        #'dependency_links': ['http://rene.f0o.com/~rene/stuff/macosx/']
--    })
-+# # NOTE: the bdist_mpkg_support is for darwin.
-+# try:
-+#     import bdist_mpkg_support
-+#     from setuptools import setup, Extension
-+# except ImportError:
-+#     pass
-+# else:
-+#     EXTRAS.update({
-+#         'options': bdist_mpkg_support.options,
-+#         'setup_requires': ['bdist_mpkg>=0.4.2'],
-+#         #'install_requires': ['pyobjc'],
-+#         #'dependency_links': ['http://rene.f0o.com/~rene/stuff/macosx/']
-+#     })
- #headers to install
- headers = glob.glob(os.path.join('src', '*.h'))
--- 
-2.1.2
-
diff --git a/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild b/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild
deleted file mode 100644 (file)
index 1b94beb..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5} )
-DISTUTILS_IN_SOURCE_BUILD=1
-inherit flag-o-matic distutils-r1 virtualx
-
-DESCRIPTION="Python bindings for SDL multimedia library"
-HOMEPAGE="http://www.pygame.org/"
-if [[ "${PV}" == *_pre* ]]; then
-       SRC_URI="http://people.apache.org/~Arfrever/gentoo/${P}.tar.xz"
-else
-       SRC_URI="http://www.pygame.org/ftp/pygame-${PV}release.tar.gz"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ~sparc x86"
-IUSE="doc examples X"
-
-DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
-       >=media-libs/sdl-image-1.2.2[png,jpeg]
-       >=media-libs/sdl-mixer-1.2.4
-       >=media-libs/sdl-ttf-2.0.6
-       >=media-libs/smpeg-0.4.4-r1
-       X? ( >=media-libs/libsdl-1.2.5[X,video] )
-       !X? ( >=media-libs/libsdl-1.2.5 )"
-RDEPEND="${DEPEND}"
-
-if [[ "${PV}" != *_pre* ]]; then
-       S="${WORKDIR}/${P}release"
-fi
-
-PATCHES=(
-       # Workaround bug #516434
-       "${FILESDIR}"/${P}-import-bdist.patch
-)
-
-DOCS=( WHATSNEW )
-
-python_configure() {
-       "${EPYTHON}" config.py -auto
-
-       if ! use X; then
-               sed -e "s:^scrap :#&:" -i Setup || die "sed failed"
-       fi
-
-       # Disable automagic dependency on PortMidi.
-       sed -e "s:^pypm :#&:" -i Setup || die "sed failed"
-
-       sed -i -e "s/import _camera/from pygame &/g" lib/camera.py || die #415593
-}
-
-python_compile() {
-       if [[ ${EPYTHON} == python2* ]]; then
-               local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
-
-               append-flags -fno-strict-aliasing
-       fi
-
-       distutils-r1_python_compile
-}
-
-python_test() {
-       VIRTUALX_COMMAND="${PYTHON}" virtualmake run_tests.py
-}
-
-python_install() {
-       distutils-r1_python_install
-
-       # Bug #497720
-       rm -fr "${D}"$(python_get_sitedir)/pygame/{docs,examples,tests}/ || die
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       if use doc; then
-               dohtml -r docs/*
-       fi
-
-       if use examples; then
-               insinto /usr/share/doc/${PF}/examples
-               doins -r examples/*
-       fi
-}