sys-fs/fragview: New package
authorLucian Poston <lucianposton@pm.me>
Wed, 1 Aug 2018 23:11:50 +0000 (16:11 -0700)
committerMichał Górny <mgorny@gentoo.org>
Wed, 22 Aug 2018 20:32:39 +0000 (22:32 +0200)
Closes: https://bugs.gentoo.org/662614
Closes: https://github.com/gentoo/gentoo/pull/9417
Package-Manager: Portage-2.3.40, Repoman-2.3.9

sys-fs/fragview/Manifest [new file with mode: 0644]
sys-fs/fragview/files/fragview-0.1.1-fix-linking.patch [new file with mode: 0644]
sys-fs/fragview/fragview-0.1.1.ebuild [new file with mode: 0644]
sys-fs/fragview/fragview-9999.ebuild [new file with mode: 0644]
sys-fs/fragview/metadata.xml [new file with mode: 0644]

diff --git a/sys-fs/fragview/Manifest b/sys-fs/fragview/Manifest
new file mode 100644 (file)
index 0000000..0e05eb4
--- /dev/null
@@ -0,0 +1 @@
+DIST fragview-0.1.1.tar.gz 20439 BLAKE2B 827275562fadcce5fc1dc210816ab5a2108863538dfb1892f677fb94e26ea348712f5c9534405d4d056435f1d5c38427eafce7de0af35839bc69da98dcedb9b5 SHA512 aa28f57e2ba5fbba48fd9d8d471ac8e90c056309b6f44cc1e320dbbaea2105c622a6803a04be23893b8e284cd53112f2d1fe73a97e7333937892b35742e5495f
diff --git a/sys-fs/fragview/files/fragview-0.1.1-fix-linking.patch b/sys-fs/fragview/files/fragview-0.1.1-fix-linking.patch
new file mode 100644 (file)
index 0000000..2eadf02
--- /dev/null
@@ -0,0 +1,46 @@
+From 11ab3027fda015798b92fd7e44cb5e3289f41542 Mon Sep 17 00:00:00 2001
+From: Rinat <ibragimovrinat@mail.ru>
+Date: Thu, 18 Jul 2013 12:03:30 +0400
+Subject: [PATCH] fix linking with "-Wl,--as-needed"
+
+https://github.com/i-rinat/fragview/issues/2
+
+
+https://github.com/i-rinat/fragview/commit/11ab3027fda015798b92fd7e44cb5e3289f41542
+
+
+---
+ CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d7003e4..fbd7cbb 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -43,13 +43,13 @@ add_executable (fileseverity
+ )
+ target_link_libraries (fragview
+-      ${GTKMM_LIBRARIES}
+       clusters
++      ${GTKMM_LIBRARIES}
+ )
+ target_link_libraries (fileseverity
+-      ${GLIBMM_LIBRARIES}
+       clusters
++      ${GLIBMM_LIBRARIES}
+ )
+ add_executable (fragdb
+@@ -57,9 +57,9 @@ add_executable (fragdb
+ )
+ target_link_libraries (fragdb
++      clusters
+       ${GLIBMM_LIBRARIES}
+       ${SQLITE3_LIBRARIES}
+-      clusters
+ )
+ install (TARGETS fileseverity fragdb fragview
diff --git a/sys-fs/fragview/fragview-0.1.1.ebuild b/sys-fs/fragview/fragview-0.1.1.ebuild
new file mode 100644 (file)
index 0000000..5e531de
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/i-rinat/fragview.git"
+else
+       SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Disk fragmentation visualizer based on FIEMAP and FIBMAP ioctls"
+HOMEPAGE="https://github.com/i-rinat/fragview"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+       dev-cpp/glibmm:2
+       dev-cpp/gtkmm:3.0
+       dev-db/sqlite:3
+       dev-libs/boost:=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-linking.patch" )
diff --git a/sys-fs/fragview/fragview-9999.ebuild b/sys-fs/fragview/fragview-9999.ebuild
new file mode 100644 (file)
index 0000000..679d625
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/i-rinat/fragview.git"
+else
+       SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Disk fragmentation visualizer based on FIEMAP and FIBMAP ioctls"
+HOMEPAGE="https://github.com/i-rinat/fragview"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+       dev-cpp/glibmm:2
+       dev-cpp/gtkmm:3.0
+       dev-db/sqlite:3
+       dev-libs/boost:=
+"
+RDEPEND="${DEPEND}"
diff --git a/sys-fs/fragview/metadata.xml b/sys-fs/fragview/metadata.xml
new file mode 100644 (file)
index 0000000..500b2e4
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>lucianposton@pm.me</email>
+               <name>Lucian Poston</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">i-rinat/fragview</remote-id>
+       </upstream>
+</pkgmetadata>