media-libs/sbc: Bump to 1.4
authorPacho Ramos <pacho@gentoo.org>
Sat, 19 Jan 2019 08:21:01 +0000 (09:21 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 19 Jan 2019 08:56:24 +0000 (09:56 +0100)
Thanks-to: Joakim Tjernlund
Closes: https://bugs.gentoo.org/675580
Package-Manager: Portage-2.3.55, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
media-libs/sbc/Manifest
media-libs/sbc/sbc-1.4.ebuild [new file with mode: 0644]

index 88411f4415097d4b625be205c58bdd7dfad52fdf..b9cce8c6651befcf1b3b85f5fec6035fe6d75ad6 100644 (file)
@@ -1 +1,2 @@
 DIST sbc-1.3.tar.xz 246292 BLAKE2B 6d628f4f5fe592b04255a965b08a85736c75d16e4caa3a5fda1dad57a5a47a82accd5e61ae48adfaf9ac1a478e20b5fa02e7a34c87fda0ac79666f616c4356e6 SHA512 c11cb1ede8abdb226d404ce34307d217b716b91cbe550ed90cb5387b062b7b97a6b7a81371de6f462d8c1429cb3299869a1bda347fa175e9d81cfa2bc2056c8b
+DIST sbc-1.4.tar.xz 250656 BLAKE2B a5b59a0ac209b44843af49e63f7b6a6b397b3905f0efc52c18a3b92785d297d39dad80f5b124e97c50a9535f892f1451bf0a2945ba223a522eafbcad46eaad9d SHA512 f35250c202034e93ce4046d29883d76b162164d42fb59e6af8ff5e57f197244238f5f8087309cef2d44755c179e7f0869cf096735c8de510b1ac7e0f6c29d84f
diff --git a/media-libs/sbc/sbc-1.4.ebuild b/media-libs/sbc/sbc-1.4.ebuild
new file mode 100644 (file)
index 0000000..5da8220
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib multilib-minimal
+
+DESCRIPTION="Audio codec to connect bluetooth HQ audio devices as headphones or loudspeakers"
+HOMEPAGE="https://git.kernel.org/?p=bluetooth/sbc.git http://www.bluez.org/sbc-10/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+# --enable-tester is building src/sbctester but the tarball is missing required
+# .wav file to execute it
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+       ECONF_SOURCE=${S} \
+       econf \
+               $(use_enable static-libs static) \
+               --disable-tester
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       find "${D}" -name '*.la' -delete || die
+}