sys-devel/llvm-common: Add 9.0 branch live ebuild
authorMichał Górny <mgorny@gentoo.org>
Sun, 21 Jul 2019 07:13:06 +0000 (09:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 21 Jul 2019 07:33:36 +0000 (09:33 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/llvm-common/llvm-common-9.0.9999.ebuild [new file with mode: 0644]

diff --git a/sys-devel/llvm-common/llvm-common-9.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-9.0.9999.ebuild
new file mode 100644 (file)
index 0000000..ff56f93
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
+       https://github.com/llvm-mirror/llvm.git"
+EGIT_BRANCH="release_90"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' utils/vim
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+       insinto /usr/share/vim/vimfiles
+       doins -r utils/vim/*/
+       # some users may find it useful
+       newdoc utils/vim/README README.vim
+       dodoc utils/vim/vimrc
+}