app-arch/p7zip: fix broken sed to use pipes
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 6 May 2019 20:38:38 +0000 (15:38 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 6 May 2019 20:38:56 +0000 (15:38 -0500)
Fixes: https://bugs.gentoo.org/685166
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-arch/p7zip/p7zip-16.02-r4.ebuild

index dc858bf58b871deadc863bb72ea1f0d6552bce5e..e71c79f0fb00ecba7fa469612c88a4d948ba34bb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -44,11 +44,11 @@ src_prepare() {
        fi
 
        sed \
-               -e 's:-m32 ::g' \
-               -e 's:-m64 ::g' \
-               -e 's:-pipe::g' \
-               -e '/ALLFLAGS/s:-s ::' \
-               -e "/OPTFLAGS=/s:=.*:=${CXXFLAGS}:" \
+               -e 's|-m32 ||g' \
+               -e 's|-m64 ||g' \
+               -e 's|-pipe||g' \
+               -e '/ALLFLAGS/s|-s ||' \
+               -e "/OPTFLAGS=/s|=.*|=${CXXFLAGS}|" \
                -i makefile* || die
 
        # remove non-free RAR codec