sci-biology/arb: remove last rited package
authorMikle Kolyada <zlogene@gentoo.org>
Thu, 2 May 2019 18:44:18 +0000 (21:44 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Thu, 2 May 2019 18:44:18 +0000 (21:44 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
sci-biology/arb/Manifest [deleted file]
sci-biology/arb/arb-6.0.6.ebuild [deleted file]
sci-biology/arb/files/arb-6.0.6-arb_install.patch [deleted file]
sci-biology/arb/files/arb-6.0.6-glapi.patch [deleted file]
sci-biology/arb/files/arb-6.0.6-tc-flags.patch [deleted file]
sci-biology/arb/metadata.xml [deleted file]

diff --git a/sci-biology/arb/Manifest b/sci-biology/arb/Manifest
deleted file mode 100644 (file)
index 4f19d30..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST arb-6.0.6.tgz 13286019 BLAKE2B fd9591321111363013084030aef7130ccac580aeb9b16e93e72613dc0b3922873aa3f3b1e76d28c1ed14846c0b0d2d497257366fc5deebf4c40c79f0b7eee859 SHA512 053d4d964d8a299f86d4cab9113f0d2181780bf51e0ccec0459a4d568d09bb4e9723fa8493d8e4fa5c72e6d1f022241721cadf7ceb75ee27142d48f2f9f269b4
diff --git a/sci-biology/arb/arb-6.0.6.ebuild b/sci-biology/arb/arb-6.0.6.ebuild
deleted file mode 100644 (file)
index e2f81e0..0000000
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Tools for DNA/RNA sequence database handling and phylogenetic analysis"
-HOMEPAGE="http://www.arb-home.de/"
-SRC_URI="http://download.arb-home.de/release/${P}/${P}-source.tgz -> ${P}.tgz"
-
-SLOT="0"
-LICENSE="arb"
-IUSE="debug +opengl test"
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="app-text/sablotron
-       media-libs/libpng:=
-       media-libs/tiff:=
-       www-client/lynx
-       x11-libs/libXaw
-       x11-libs/libXpm
-       x11-libs/motif:0
-       opengl? (
-               media-libs/glew:=
-               media-libs/freeglut
-               || (
-                       media-libs/mesa[motif]
-                       ( media-libs/mesa x11-libs/libGLw ) ) )"
-DEPEND="${CDEPEND}
-       sys-process/time
-       x11-misc/makedepend"
-RDEPEND="${CDEPEND}
-       sci-visualization/gnuplot"
-
-# Almost half of tests are broken with debug
-RESTRICT="debug? ( test )"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-6.0.6-glapi.patch
-       "${FILESDIR}"/${PN}-6.0.6-tc-flags.patch
-       "${FILESDIR}"/${PN}-6.0.6-arb_install.patch
-)
-
-src_unpack() {
-       default
-       mv arbsrc* ${P} || die
-}
-
-src_prepare() {
-       default
-
-       cp config.makefile.template config.makefile
-       mkdir "${S}"/patches.arb || die  # Test script expects ${ARBHOME}/patches.arb to exist
-
-       if use amd64; then
-               sed -i -e 's@ARB_64 := 0@ARB_64 := 1@' config.makefile || die
-       fi
-       if use opengl; then
-               sed -i -e 's@OPENGL := 0@OPENGL := 1@' config.makefile || die
-       fi
-       if use test; then
-               sed -i -e 's@UNIT_TESTS := 0@UNIT_TESTS := 1@' config.makefile || die
-       fi
-       if use debug; then
-               sed -i -e 's@DEBUG := 0@DEBUG := 1@' \
-               -e 's@DEBUG_GRAPHICS := 0@DEBUG_GRAPHICS := 1@' config.makefile || die
-       fi
-}
-
-src_compile() {
-       emake ARBHOME="${S}" PATH="${S}/bin:${PATH}" LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
-               CC="$(tc-getCC)" CXX="$(tc-getCXX)" build
-}
-
-src_test() {
-       emake ARBHOME="${S}" PATH="${S}/bin:${PATH}" LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
-               CC="$(tc-getCC)" CXX="$(tc-getCXX)" run_tests
-}
-
-src_install() {
-       emake ARBHOME="${S}" PATH="${S}/bin:${PATH}" LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}" \
-               CC="$(tc-getCC)" CXX="$(tc-getCXX)" prepare_libdir
-       "${S}"/util/arb_compress  || die
-       if use amd64; then
-               mv arb.tgz arb.64.gentoo.tgz || die
-       fi
-       if use x86; then
-               mv arb.tgz arb.32.gentoo.tgz || die
-       fi
-       ln -s arb.*.tgz arb.tgz || die
-       ARBHOME="${D}/opt/arb" "${S}/arb_install.sh" || die
-
-       cat <<- EOF > "${S}/99${PN}" || die
-               ARBHOME=/opt/arb
-               PATH=/opt/arb/bin
-               LD_LIBRARY_PATH=/opt/arb/lib
-       EOF
-       doenvd "${S}/99${PN}"
-}
diff --git a/sci-biology/arb/files/arb-6.0.6-arb_install.patch b/sci-biology/arb/files/arb-6.0.6-arb_install.patch
deleted file mode 100644 (file)
index 926c8e0..0000000
+++ /dev/null
@@ -1,99 +0,0 @@
---- a/arb_install.sh
-+++ b/arb_install.sh
-@@ -13,7 +13,6 @@
- cont() {
-     echo "Warning: $@" 1>&2
-     echo 'Do you want to continue [y]'
--    read var
-     case "$var" in
-         n) err "Script aborted by user" ;;
-         *) echo 'Continuing...' ;;
-@@ -79,7 +78,6 @@
- fi
- echo "Enter full installation path: [${ARBHOME:-/usr/arb}]"
--read ARBHOMEI
- echo
- echo
-@@ -127,7 +125,6 @@
-         echo '  You can delete the old directory before installing ARB'
-         echo '  or only update/change options of the old version.'
-         echo 'Delete old directory (y/n)[n]?'
--        read delete_dir
-         echo
-         case "$delete_dir" in
-             y)
-@@ -163,7 +160,6 @@
-     separator
-     echo "Old ARB package found (type n to change only some options)."
-     echo "  Do you want to update the old package: (y/n)[y]"
--    read var;
-     case "$var" in
-         n)
-         echo "Old version unchanged";;
-@@ -197,7 +193,6 @@
- echo '          2. "Path" to link pt_server data directory to'
- echo "              (if you choose this option you won't loose your PT-Servers when doing future software updates)"
- echo 'Enter path:'
--read pt_dir
- echo
- case "$pt_dir" in
-     "")
-@@ -222,7 +217,6 @@
-         if test -d ${ARBHOME}/lib/pts; then
-             echo ">>> data in default location found"
-             echo 'Do you want to remove old ptserver data (recommended)? [y]'
--            read ANSWER
-             case "$ANSWER" in
-                 n) echo 'data not deleted' ;;
-                 *) rm -r lib/pts
-@@ -247,7 +241,6 @@
- echo '          n: if PT_SERVER files shall only be changable by administrator'
- echo '  or simply press return to keep the settings of an old installation.'
- echo 'Should everybody be allowed to build/update PT_SERVER files (y/n/dont_change)[dont_change]?'
--read var
- echo
- case "$var" in
-     y)
-@@ -273,7 +266,6 @@
- echo '          n: if there are some mean untrusty users'
- echo '  or simply press return to keep the old settings'
- echo 'Do you trust your users (y/n/dont_change)[dont_change]?'
--read var
- echo
- case "$var" in
-     y)
-@@ -310,7 +302,6 @@
-     echo 'Choose (s/n)[s]?'
- fi
--read var
- echo
-@@ -322,7 +313,6 @@
-     n)
-     separator
-     echo "Enter the name of your host for the pt_server"
--    read host
-     echo "Checking connection to $host"
-     if ssh $host ls >/dev/zero; then
-         echo ">>> ssh $host ok"
-@@ -341,7 +331,7 @@
- echo ">>> Installation Complete"
- separator
--SHELL_ANS=0
-+SHELL_ANS=1
- while [ "$SHELL_ANS" = "0" ]; do
-@@ -359,7 +349,6 @@
-     echo "Enter (1,2 or 3) to achieve further installation instructions:"
--    read var
-     echo '';
-     echo '**********************************************************************************************';
diff --git a/sci-biology/arb/files/arb-6.0.6-glapi.patch b/sci-biology/arb/files/arb-6.0.6-glapi.patch
deleted file mode 100644 (file)
index 755cb68..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-When built with USE=opengl, the macro GLAPI either doesn't get defined
-or gets undefed in some header.  Header <GL/GLwMDrawA.h> seems to expect
-it to be defined as 'extern', as defining it as '__attribute__((visibility("default")))'
-leads to multiple definition errors.
-
---- a/RNA3D/RNA3D_GlobalHeader.hxx
-+++ b/RNA3D/RNA3D_GlobalHeader.hxx
-@@ -44,6 +44,7 @@
- // Undefining it here does the job:
- #undef __GLX_glx_h__
- #include <GL/glx.h>
-+#define GLAPI extern
- #endif // OPEN_GL_WAY_TO_INCLUDE == 3
- // ------------------------------
diff --git a/sci-biology/arb/files/arb-6.0.6-tc-flags.patch b/sci-biology/arb/files/arb-6.0.6-tc-flags.patch
deleted file mode 100644 (file)
index 4c8f22d..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -61,8 +61,8 @@
- # compiler settings:
- ifneq ($(CC),use__A_CC__instead_of__CC)
--A_CC:=$(CC)# compile C
--A_CXX:=$(CXX)# compile C++
-+A_CC:=${CC}# compile C
-+A_CXX:=${CXX}# compile C++
- # uncomment to ensure no submakefile uses CC and CXX directly
- override CC:=use__A_CC__instead_of__CC
-@@ -119,12 +119,7 @@
-  endif
- endif
--ifeq ($(USE_CLANG),1)
--# accept all clang versions:
- ALLOWED_COMPILER_VERSIONS=$(COMPILER_VERSION)
--else
--ALLOWED_COMPILER_VERSIONS=$(ALLOWED_gcc_VERSIONS)
--endif
- COMPILER_VERSION_ALLOWED=$(strip $(subst ___,,$(foreach version,$(ALLOWED_COMPILER_VERSIONS),$(findstring ___$(version)___,___$(COMPILER_VERSION)___))))
-@@ -184,20 +179,13 @@
- shared_cflags :=# flags for shared lib compilation
- lflags :=# linker flags
--clflags :=# linker flags (when passed through gcc)
-+clflags := ${LDFLAGS} # linker flags (when passed through gcc)
- extended_warnings :=# warning flags for C and C++-compiler
- extended_cpp_warnings :=# warning flags for C++-compiler only
- ifeq ($(DEBUG),0)
-       dflags := -DNDEBUG# defines
--      ifeq ($(USE_CLANG),1)
--              cflags := -O3# compiler flags (C and C++)
--      else
--              cflags := -O3# compiler flags (C and C++)
--              lflags += -O2# linker flags
--              clflags += -Wl,-O2# passthrough linker flags
--      endif
- endif
- ifeq ($(DEBIAN),1)
-@@ -526,6 +514,9 @@
-       cxxflags += $(CPPFLAGS)
- endif
-+cflags := ${CFLAGS} $(cflags)
-+cxxflags += ${CXXFLAGS}
-+
- ifeq ('$(USE_GCC_47_OR_HIGHER)','yes')
- cxxflags += -std=gnu++11# see also TEMPLATES/cxxforward.h@USE_Cxx11
- else
diff --git a/sci-biology/arb/metadata.xml b/sci-biology/arb/metadata.xml
deleted file mode 100644 (file)
index 959160f..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>sci-biology@gentoo.org</email>
-    <name>Gentoo Biology Project</name>
-  </maintainer>
-</pkgmetadata>