dev-ros/settlerlib: fix build with gcc6, bug #594318
authorAlexis Ballier <aballier@gentoo.org>
Fri, 14 Oct 2016 13:54:53 +0000 (15:54 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 14 Oct 2016 13:55:00 +0000 (15:55 +0200)
Package-Manager: portage-2.3.2

dev-ros/settlerlib/files/gcc6.patch [new file with mode: 0644]
dev-ros/settlerlib/settlerlib-0.10.14.ebuild

diff --git a/dev-ros/settlerlib/files/gcc6.patch b/dev-ros/settlerlib/files/gcc6.patch
new file mode 100644 (file)
index 0000000..4fe3a03
--- /dev/null
@@ -0,0 +1,13 @@
+Index: settlerlib/CMakeLists.txt
+===================================================================
+--- settlerlib.orig/CMakeLists.txt
++++ settlerlib/CMakeLists.txt
+@@ -9,7 +9,7 @@ catkin_package(DEPENDS Boost calibration
+ )
+ # common commands for building c++ executables and libraries
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
++include_directories(${catkin_INCLUDE_DIRS})
+ include_directories(include)
+ install(DIRECTORY ${PROJECT_SOURCE_DIR}/include/settlerlib/
+         DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
index e00b3046a233b405c3ba83dc2cedb7b62f9fc883..bb9f2466b99e42715c7d347cf676e7a5fb5f2ac3 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -22,3 +22,4 @@ RDEPEND="
 "
 DEPEND="${RDEPEND}
        test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/gcc6.patch" )