www-apps/baikal-0.6.1: version bump
authorFabian Groffen <grobian@gentoo.org>
Wed, 22 Apr 2020 07:10:37 +0000 (09:10 +0200)
committerFabian Groffen <grobian@gentoo.org>
Wed, 22 Apr 2020 07:10:37 +0000 (09:10 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
www-apps/baikal/Manifest
www-apps/baikal/baikal-0.6.1.ebuild [new file with mode: 0644]

index e75fc3fda3848b8af182e7f6714f78288cb45dda..841948ccdf5490db0cb09e72867358e05aeb4482 100644 (file)
@@ -1,2 +1,3 @@
 DIST baikal-0.5.2.zip 3426025 BLAKE2B ac13b42a3eab54e43761bd0ad958208b692919a61908a6467e710a045c6568e9ae616a54c6910b6828c4499b3f815bd96b9bee12608637b64182238725e21922 SHA512 58dd9e231840a76582a70abca89c8f73f1a26f06855eff6949ebca526a22d23bc06f281f51611aeb7f0cf8334c0ad490cfea962905e985d6c75e78e1c1d47e63
 DIST baikal-0.6.0.zip 3432758 BLAKE2B db55008e2e971fd8d6edabe38f333c32564ef34cf7f3a93ad9d67083646c9575cdf9ba1d51108c5fe9f5d385a53bd78d1406318f3a72672126b5f31cc032b104 SHA512 75cd3e30c3df4bc5057e14215b320647c9683702171671ed58ac83e12f7770454d81970f036fd96dbb9aefe0928fcf40ae11128687fd261a0dccadf15d148905
+DIST baikal-0.6.1.zip 3437686 BLAKE2B f28d3a63166a73571116759df3662c2b19c2eeeebcd7070574dfc3ee8cb046f2d94fdbc4701669291c1bb2cb2b9b92665726127c852c5457cd285f6ffbcc9b00 SHA512 d88ed9fbe1f934d52fd798165675b90972c47c9e138de61e17a14777590ebad5006c1a414a4e0119eb8fa718e01f2aadb6e1d180e23a51fb33e1b5a3539c9e38
diff --git a/www-apps/baikal/baikal-0.6.1.ebuild b/www-apps/baikal/baikal-0.6.1.ebuild
new file mode 100644 (file)
index 0000000..60941c0
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit webapp
+
+DESCRIPTION="Lightweight CalDAV+CardDAV server"
+HOMEPAGE="http://sabre.io/baikal/"
+SRC_URI="https://github.com/sabre-io/Baikal/releases/download/${PV}/${P}.zip"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~ppc64"
+IUSE="+mysql sqlite"
+REQUIRED_USE="|| ( mysql sqlite )"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-lang/php-6[ctype,filter,json,pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
+       mysql? ( virtual/mysql )
+       sqlite? ( dev-db/sqlite )
+       virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+       webapp_src_preinst
+
+       dodoc *.md
+
+       einfo "Installing web files"
+       insinto "${MY_HTDOCSDIR}"
+       doins -r html/* html/.htaccess Core vendor
+
+       einfo "Setting up container for configuration"
+       insinto /etc/${PN}
+
+       einfo "Fixing symlinks"
+       local link target
+       find "${D}${MY_HTDOCSDIR}" -type l | while read link ; do
+               target=$(readlink "${link}")
+               target=${target/..\/Core/Core}
+               rm "${link}" && ln -s "${target}" "${link}"
+       done
+       dosym /etc/${PN} "${MY_HTDOCSDIR}"/Specific
+       dosym . "${MY_HTDOCSDIR}"/html
+
+       webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+       webapp_src_install
+
+       if has_version www-servers/apache ; then
+               fowners -R apache:apache /etc/${PN}
+       elif has_version www-servers/nginx ; then
+               fowners -R nginx:nginx /etc/${PN}
+       else
+               einfo "/etc/${PN} must be owned by the webserver user for baikal"
+       fi
+}